aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/src/gprs/Makefile.am
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2010-05-11 10:01:17 +0200
committerHarald Welte <laforge@gnumonks.org>2010-05-11 10:03:34 +0200
commit0a4050c63b8ff1b80714aee6d6a133de79366eb9 (patch)
tree91750623cbc24f136b30618938917691393c2e60 /openbsc/src/gprs/Makefile.am
parentc1c1dd260a02d7679f0e1aff28f319defed950eb (diff)
[gprs] gb_proxy: Send proper BSSGP STATUS msg in error case
In order to reuse the existing bssgp_tx_* functions without pulling in the dependencies of gprs_bssgp.c, we have to move those functions to gprs_bssgp_util.c Furthermore, we can remove gbprox_nsi and replace it with bssgp_nsi, and we can do proper processing of BVC-RESET messages coming from the SGSN on the signalling BVC. In that case we need to send RESET messages to all the BSS.
Diffstat (limited to 'openbsc/src/gprs/Makefile.am')
-rw-r--r--openbsc/src/gprs/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/openbsc/src/gprs/Makefile.am b/openbsc/src/gprs/Makefile.am
index 2b4292398..7cb7ba66a 100644
--- a/openbsc/src/gprs/Makefile.am
+++ b/openbsc/src/gprs/Makefile.am
@@ -6,10 +6,11 @@ sbin_PROGRAMS = osmo-gbproxy osmo-sgsn
noinst_LIBRARIES = libsgsn.a
libsgsn_a_SOURCES = gprs_ns.c gprs_bssgp.c gprs_llc.c gsm_04_08_gprs.c \
- crc24.c gprs_sgsn.c
+ crc24.c gprs_sgsn.c gprs_bssgp_util.c
osmo_gbproxy_SOURCES = gb_proxy.c gb_proxy_main.c gb_proxy_vty.c \
- gprs_ns.c $(top_srcdir)/src/socket.c $(top_srcdir)/src/debug.c
+ gprs_ns.c gprs_bssgp_util.c \
+ $(top_srcdir)/src/socket.c $(top_srcdir)/src/debug.c
osmo_gbproxy_LDADD = $(top_builddir)/src/libvty.a
osmo_sgsn_SOURCES = sgsn_main.c sgsn_vty.c \