aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/src/gprs/Makefile.am
diff options
context:
space:
mode:
authorNeels Hofmeyr <nhofmeyr@sysmocom.de>2015-09-24 17:32:30 +0200
committerNeels Hofmeyr <nhofmeyr@sysmocom.de>2015-11-16 15:16:26 +0100
commitc8a614d2e9c56fe13c22f239be82f2a2c958e039 (patch)
treece820c172725b3072ed106ea2c233df108b8ef1d /openbsc/src/gprs/Makefile.am
parent65482c919f82b28aa53cd519c4f7799b104051c0 (diff)
Add GTP hub initial code base.
First steps towards a new GTP hub. The aim is to mux GTP connections, so that multiple SGSN <--> GGSN links can pass through a single point. Background: allow having more than one SGSN, possibly in various remote locations. The recent addition of OAP to GSUP is related to the same background idea. (This is a collapsed patch of various changes that do not make sense to review in chronological order anymore, since a lot of it has thorougly transmorphed after it was first committed.) Sponsored-by: On-Waves ehf
Diffstat (limited to 'openbsc/src/gprs/Makefile.am')
-rw-r--r--openbsc/src/gprs/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/openbsc/src/gprs/Makefile.am b/openbsc/src/gprs/Makefile.am
index c8e3696dc..0dd38f99c 100644
--- a/openbsc/src/gprs/Makefile.am
+++ b/openbsc/src/gprs/Makefile.am
@@ -11,6 +11,7 @@ noinst_HEADERS = gprs_sndcp.h
bin_PROGRAMS = osmo-gbproxy
if HAVE_LIBGTP
+bin_PROGRAMS += osmo-gtphub
if HAVE_LIBCARES
bin_PROGRAMS += osmo-sgsn
endif
@@ -33,3 +34,8 @@ osmo_sgsn_LDADD = \
$(top_builddir)/src/libcommon/libcommon.a \
-lgtp $(OSMO_LIBS) $(LIBOSMOABIS_LIBS) $(LIBCARES_LIBS) \
$(LIBCRYPTO_LIBS) -lrt
+
+osmo_gtphub_SOURCES = gtphub_main.c gtphub.c gtphub_ext.c gtphub_vty.c
+osmo_gtphub_LDADD = \
+ $(top_builddir)/src/libcommon/libcommon.a \
+ -lgtp $(LIBOSMOCORE_LIBS) $(LIBOSMOVTY_LIBS) -lrt