aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/src/gprs/Makefile.am
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <holger@moiji-mobile.com>2014-03-23 18:08:26 +0100
committerHolger Hans Peter Freyther <holger@moiji-mobile.com>2014-03-23 18:34:58 +0100
commita27303094ab8bedb0a3b3bfe771daeed10a2e0a9 (patch)
tree146d6a943d44c950ee10244691c01061624ae309 /openbsc/src/gprs/Makefile.am
parent49f9e5b6b42cae9f6083e5c69c70af0b29b15b23 (diff)
sgsn/ctrl: Add ctrl interface, implement listing subscribers
Add the control interface with no hierachy right now and implement the first command to list IMSI + Context Address of active sessions. sgsn_cmd_handle could share more code with bsc variant. Fixes: SYS#264, SYS#265
Diffstat (limited to 'openbsc/src/gprs/Makefile.am')
-rw-r--r--openbsc/src/gprs/Makefile.am9
1 files changed, 6 insertions, 3 deletions
diff --git a/openbsc/src/gprs/Makefile.am b/openbsc/src/gprs/Makefile.am
index f4b135467..90c376c79 100644
--- a/openbsc/src/gprs/Makefile.am
+++ b/openbsc/src/gprs/Makefile.am
@@ -19,6 +19,9 @@ osmo_gbproxy_LDADD = $(top_builddir)/src/libcommon/libcommon.a \
osmo_sgsn_SOURCES = gprs_gmm.c gprs_sgsn.c gprs_sndcp.c gprs_sndcp_vty.c \
sgsn_main.c sgsn_vty.c sgsn_libgtp.c \
- gprs_llc.c gprs_llc_vty.c crc24.c
-osmo_sgsn_LDADD = $(top_builddir)/src/libcommon/libcommon.a \
- -lgtp $(OSMO_LIBS)
+ gprs_llc.c gprs_llc_vty.c crc24.c \
+ sgsn_ctrl.c
+osmo_sgsn_LDADD = \
+ $(top_builddir)/src/libctrl/libctrl.a \
+ $(top_builddir)/src/libcommon/libcommon.a \
+ -lgtp $(OSMO_LIBS) $(LIBOSMOABIS_LIBS)