aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/src/gprs/Makefile.am
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2010-05-18 00:20:21 +0200
committerHarald Welte <laforge@gnumonks.org>2010-05-18 00:20:21 +0200
commit03800ba868f732eb1d8d8722568e9f06e51270ef (patch)
treef5c71b4be07c8ee98735e552f176c59dea1a18ee /openbsc/src/gprs/Makefile.am
parentd9a55f67acdcc9a0f63ac48c34926b15b72180da (diff)
[GPRS] Build osmo-sgsn only if libgtp is available
Diffstat (limited to 'openbsc/src/gprs/Makefile.am')
-rw-r--r--openbsc/src/gprs/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/openbsc/src/gprs/Makefile.am b/openbsc/src/gprs/Makefile.am
index 098961ba7..cebcfebc3 100644
--- a/openbsc/src/gprs/Makefile.am
+++ b/openbsc/src/gprs/Makefile.am
@@ -2,7 +2,12 @@ INCLUDES = $(all_includes) -I$(top_srcdir)/include -I$(top_builddir)
AM_CFLAGS=-Wall $(LIBOSMOCORE_CFLAGS)
AM_LDFLAGS = $(LIBOSMOCORE_LIBS)
+if HAVE_LIBGTP
sbin_PROGRAMS = osmo-gbproxy osmo-sgsn
+else
+sbin_PROGRAMS = osmo-gbproxy
+endif
+
noinst_LIBRARIES = libsgsn.a
libsgsn_a_SOURCES = gprs_ns.c gprs_bssgp.c gprs_llc.c gprs_gmm.c \