aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/src/gprs/Makefile.am
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2010-05-04 07:41:59 +0200
committerHarald Welte <laforge@gnumonks.org>2010-05-04 07:41:59 +0200
commite236596bf42aec7520f2d7a879bb8d2aef7afad0 (patch)
tree5db2e10e93509491e0c1a55f05ee52bbc80235b1 /openbsc/src/gprs/Makefile.am
parentce662943f3a0d49606ca6563aa700b2660abe3d4 (diff)
[gprs] Move all GPRS related code to src/gprs subdirectory
Diffstat (limited to 'openbsc/src/gprs/Makefile.am')
-rw-r--r--openbsc/src/gprs/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/openbsc/src/gprs/Makefile.am b/openbsc/src/gprs/Makefile.am
new file mode 100644
index 000000000..ac177f7fd
--- /dev/null
+++ b/openbsc/src/gprs/Makefile.am
@@ -0,0 +1,17 @@
+INCLUDES = $(all_includes) -I$(top_srcdir)/include -I$(top_builddir)
+AM_CFLAGS=-Wall $(LIBOSMOCORE_CFLAGS)
+AM_LDFLAGS = $(LIBOSMOCORE_LIBS)
+
+sbin_PROGRAMS = osmo-gbproxy osmo-sgsn
+noinst_LIBRARIES = libsgsn.a
+
+libsgsn_a_SOURCES = gprs_ns.c gprs_bssgp.c gprs_llc.c gsm_04_08_gprs.c \
+ crc24.c gprs_sgsn.c
+
+osmo_gbproxy_SOURCES = gb_proxy.c gb_proxy_main.c gb_proxy_vty.c \
+ gprs_ns.c ../socket.c ../debug.c
+osmo_gbproxy_LDADD = ../libvty.a
+
+osmo_sgsn_SOURCES = sgsn_main.c sgsn_vty.c \
+ ../socket.c ../debug.c
+osmo_sgsn_LDADD = ../libvty.a libsgsn.a