aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/src/Makefile.am
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <zecke@selfish.org>2010-07-30 02:53:14 +0800
committerHolger Hans Peter Freyther <zecke@selfish.org>2010-07-31 04:09:38 +0800
commit30e1ae923db16c480cf210a29c8befa57a69202b (patch)
treefc64d6d9e4b4b7e3bb5b5e798ed284a2206b821f /openbsc/src/Makefile.am
parentc44db4a5341c1c86de784bb74d4dbd2063a4c010 (diff)
sccp: Use the external libosmo-sccp as sccp implementation
Add --enable-nat and --enable-osmo-bsc to build applications requiring the Osmo SCCP library to be installed. We are not using autodiscover as this is out of fashion.
Diffstat (limited to 'openbsc/src/Makefile.am')
-rw-r--r--openbsc/src/Makefile.am17
1 files changed, 10 insertions, 7 deletions
diff --git a/openbsc/src/Makefile.am b/openbsc/src/Makefile.am
index af77f503c..523ff6c34 100644
--- a/openbsc/src/Makefile.am
+++ b/openbsc/src/Makefile.am
@@ -3,13 +3,18 @@ AM_CFLAGS=-Wall $(LIBOSMOCORE_CFLAGS) $(LIBOSMOVTY_CFLAGS)
AM_LDFLAGS = $(LIBOSMOCORE_LIBS)
# build current directory before building gprs
-SUBDIRS = . ipaccess gprs nat bsc
+SUBDIRS = . ipaccess gprs
-sbin_PROGRAMS = bsc_hack bs11_config isdnsync bsc_mgcp
-noinst_LIBRARIES = libbsc.a libmsc.a libvty.a libsccp.a libmgcp.a
+# Conditional modules
+if BUILD_NAT
+SUBDIRS += nat
+endif
+if BUILD_BSC
+SUBDIRS += bsc
+endif
-bscdir = $(libdir)
-bsc_LIBRARIES = libsccp.a
+sbin_PROGRAMS = bsc_hack bs11_config isdnsync bsc_mgcp
+noinst_LIBRARIES = libbsc.a libmsc.a libvty.a libmgcp.a
libbsc_a_SOURCES = abis_rsl.c abis_nm.c gsm_data.c gsm_04_08_utils.c \
chan_alloc.c debug.c socket.c abis_nm_vty.c \
@@ -28,8 +33,6 @@ libmsc_a_SOURCES = gsm_subscriber.c db.c \
libvty_a_SOURCES = common_vty.c
-libsccp_a_SOURCES = sccp/sccp.c
-
libmgcp_a_SOURCES = mgcp/mgcp_protocol.c mgcp/mgcp_network.c mgcp/mgcp_vty.c
bsc_hack_SOURCES = bsc_hack.c bsc_init.c bsc_vty.c vty_interface_layer3.c