aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/src/Makefile.am
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2009-07-28 18:25:29 +0200
committerHarald Welte <laforge@gnumonks.org>2009-07-28 18:25:29 +0200
commit805f64486b490d8c7042235e69565755074b768e (patch)
treed9e4fd82232b2dd80a19ecba40a1509a8fac2501 /openbsc/src/Makefile.am
parentaea9a98dc2dfbbad0daf434c97bc6d2a4d3384f2 (diff)
add RTP proxy mode for ip.access
Up until now, we only supported direct RTP streams between ip.access BTS. With this commit, the user can specify '-P' to the command line to enable a RTP/RTCP proxy inside OpenBSC. The nanoBTS will then send all their voice data to OpenBSC, which will relay it to the respective destination BTS (which can be the same BTS). The default behaviour remains unchanged. Without '-P' on the command line, RTP/RTCP is exchanged directly.
Diffstat (limited to 'openbsc/src/Makefile.am')
-rw-r--r--openbsc/src/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/openbsc/src/Makefile.am b/openbsc/src/Makefile.am
index c6e9dae53..ed63c8e31 100644
--- a/openbsc/src/Makefile.am
+++ b/openbsc/src/Makefile.am
@@ -10,7 +10,7 @@ libbsc_a_SOURCES = abis_rsl.c abis_nm.c gsm_04_08.c gsm_data.c mncc.c \
gsm_04_11.c telnet_interface.c subchan_demux.c \
trau_frame.c trau_mux.c paging.c e1_config.c e1_input.c tlv_parser.c \
input/misdn.c input/ipaccess.c signal.c gsm_utils.c talloc.c \
- transaction.c
+ transaction.c rtp_proxy.c
libvty_a_SOURCES = vty/buffer.c vty/command.c vty/vector.c vty/vty.c