aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/src/Makefile.am
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <zecke@selfish.org>2010-02-07 14:57:06 +0100
committerHolger Hans Peter Freyther <zecke@selfish.org>2010-02-08 13:44:48 +0100
commitbe807e4250dfcde9ad65508ce10647487694f6b3 (patch)
tree89683855830c7a7836a9877e5f2ab44b086ea866 /openbsc/src/Makefile.am
parent71ddbf5c4f75b361c04d37e0de5514fe7f390496 (diff)
[nat] Add VTY support to the BSC nat application
* Create struct bsc_nat and move the various lists into this structure * Create the VTY code * Call the VTY init and parsing code * Create functions to create the types.. * Add some stuff into the bsc_connection to be used for the NAT with proper config files. E.g. to close the connection if the BSC does not respond to a given command.
Diffstat (limited to 'openbsc/src/Makefile.am')
-rw-r--r--openbsc/src/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/openbsc/src/Makefile.am b/openbsc/src/Makefile.am
index b8a631048..0e411775e 100644
--- a/openbsc/src/Makefile.am
+++ b/openbsc/src/Makefile.am
@@ -43,5 +43,5 @@ isdnsync_SOURCES = isdnsync.c
bsc_mgcp_SOURCES = bsc_mgcp.c msgb.c talloc.c debug.c select.c timer.c telnet_interface.c
bsc_mgcp_LDADD = libvty.a
-bsc_nat_SOURCES = nat/bsc_nat.c nat/bsc_filter.c bsc_msc.c
-bsc_nat_LDADD = libbsc.a libsccp.a
+bsc_nat_SOURCES = nat/bsc_nat.c nat/bsc_filter.c nat/bsc_nat_vty.c bsc_msc.c
+bsc_nat_LDADD = libvty.a libbsc.a libsccp.a