aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/src/Makefile.am
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <zecke@selfish.org>2011-01-06 13:31:41 +0100
committerHolger Hans Peter Freyther <zecke@selfish.org>2011-01-06 14:31:16 +0100
commit6c4d2443b478e51741901676c990db8af1ec2ca2 (patch)
tree70b957fe701039d618d805ddbef86e84942a3017 /openbsc/src/Makefile.am
parent04d362f79d0e24a8ef45eddb9ed217834efdd20d (diff)
rtp: Move the RTP Proxy code out of RSL into the BSC/MSC domain
Instead of creating the sockets in the RSL code we will do this in the CRCX_ACK, MDCX_ACK, DLCX_IND signal handler of gsm_04_08. Introduce a handover signal so we can repatch the RTP sockets in the gsm_04_08 as well.
Diffstat (limited to 'openbsc/src/Makefile.am')
-rw-r--r--openbsc/src/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/openbsc/src/Makefile.am b/openbsc/src/Makefile.am
index cc69a729d..c86fc26c9 100644
--- a/openbsc/src/Makefile.am
+++ b/openbsc/src/Makefile.am
@@ -22,7 +22,7 @@ libbsc_a_SOURCES = abis_rsl.c abis_nm.c gsm_data.c gsm_04_08_utils.c \
trau_frame.c trau_mux.c paging.c e1_config.c e1_input.c \
input/misdn.c input/ipaccess.c handover_logic.c \
talloc_ctx.c system_information.c rest_octets.c \
- rtp_proxy.c bts_siemens_bs11.c bts_ipaccess_nanobts.c \
+ bts_siemens_bs11.c bts_ipaccess_nanobts.c \
bts_unknown.c bsc_version.c bsc_api.c bsc_vty.c meas_rep.c gsm_04_80.c
libmsc_a_SOURCES = gsm_subscriber.c db.c \
@@ -30,7 +30,7 @@ libmsc_a_SOURCES = gsm_subscriber.c db.c \
gsm_04_08.c gsm_04_11.c transaction.c \
token_auth.c rrlp.c ussd.c silent_call.c \
handover_decision.c auth.c \
- osmo_msc.c
+ osmo_msc.c rtp_proxy.c
libvty_a_SOURCES = common_vty.c