aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/src/Makefile.am
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2011-03-03 23:36:48 +0100
committerHarald Welte <laforge@gnumonks.org>2011-03-03 23:36:48 +0100
commita17faf8512992a53a14e8b615f5369be05c5f0cc (patch)
tree044ab53a68634ddcf12130bbc1275e86423e449f /openbsc/src/Makefile.am
parent31c00f7d6fa63937f2c973157d196a427f6eef95 (diff)
Rename bsc_nat -> osmo-bsc_nat and bsc_mgcp -> osmo-bsc_mgcp
This now enforces a unique structure: All of our main daemon programs start with an "osmo-" prefix.
Diffstat (limited to 'openbsc/src/Makefile.am')
-rw-r--r--openbsc/src/Makefile.am9
1 files changed, 2 insertions, 7 deletions
diff --git a/openbsc/src/Makefile.am b/openbsc/src/Makefile.am
index e4b2b960c..1a8ec6483 100644
--- a/openbsc/src/Makefile.am
+++ b/openbsc/src/Makefile.am
@@ -2,17 +2,12 @@ INCLUDES = $(all_includes) -I$(top_srcdir)/include -I$(top_builddir)
AM_CFLAGS=-Wall $(LIBOSMOCORE_CFLAGS) $(LIBOSMOVTY_CFLAGS) $(COVERAGE_CFLAGS)
AM_LDFLAGS = $(LIBOSMOCORE_LIBS) $(COVERAGE_LDFLAGS)
-SUBDIRS = common abis mgcp bsc trau osmo-nitb utils ipaccess gprs
+SUBDIRS = common abis mgcp bsc trau osmo-nitb osmo-bsc_mgcp utils ipaccess gprs
# Conditional modules
if BUILD_NAT
-SUBDIRS += nat
+SUBDIRS += osmo-bsc_nat
endif
if BUILD_BSC
SUBDIRS += osmo-bsc
endif
-
-bin_PROGRAMS = bsc_mgcp
-
-bsc_mgcp_SOURCES = mgcp/mgcp_main.c
-bsc_mgcp_LDADD = common/libcommon.a mgcp/libmgcp.a $(LIBOSMOVTY_LIBS)