aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/configure.in
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <zecke@selfish.org>2011-04-17 11:18:44 +0200
committerHolger Hans Peter Freyther <zecke@selfish.org>2011-04-17 11:18:44 +0200
commit07ab5e47b10bc6c84fb749811ab8c3d366ff9eee (patch)
treef1a58a43c694cfa0782973d8caabd8ec3b0ac9e9 /openbsc/configure.in
parent55ef2d362a043082280a5012707ae2d7b5e2cb1b (diff)
msc: Start compiling a MSC only applicationzecke/osmo-msc
This application has no support for Abis but will use the A-link to communicate with a BSC. Right now a lot of symbols are stubbed out.
Diffstat (limited to 'openbsc/configure.in')
-rw-r--r--openbsc/configure.in11
1 files changed, 11 insertions, 0 deletions
diff --git a/openbsc/configure.in b/openbsc/configure.in
index ef2be591f..a65e1a389 100644
--- a/openbsc/configure.in
+++ b/openbsc/configure.in
@@ -43,6 +43,16 @@ AC_ARG_ENABLE([osmo-bsc], [AS_HELP_STRING([--enable-osmo-bsc], [Build the Osmo B
])
AM_CONDITIONAL(BUILD_BSC, test "x$osmo_ac_build_bsc" = "xyes")
+AC_ARG_ENABLE([osmo-msc], [AS_HELP_STRING([--enable-osmo-msc], [Build the Osmo MSC])],
+ [
+ PKG_CHECK_MODULES(LIBOSMOSCCP, libosmo-sccp >= 0.0.2)
+ osmo_ac_build_msc="yes"
+ ],
+ [
+ osmo_ac_build_msc="no"
+ ])
+AM_CONDITIONAL(BUILD_MSC, test "x$osmo_ac_build_msc" = "xyes")
+
PKG_CHECK_MODULES(LIBOSMOCORE, libosmocore >= 0.2.0)
PKG_CHECK_MODULES(LIBOSMOVTY, libosmovty >= 0.2.0)
PKG_CHECK_MODULES(LIBOSMOGSM, libosmogsm >= 0.2.0)
@@ -99,6 +109,7 @@ AC_OUTPUT(
src/osmo-bsc/Makefile
src/osmo-bsc_nat/Makefile
src/osmo-bsc_mgcp/Makefile
+ src/osmo-msc/Makefile
src/ipaccess/Makefile
src/utils/Makefile
src/libgb/Makefile