aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/configure.ac
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2015-01-01 13:23:49 +0100
committerHarald Welte <laforge@gnumonks.org>2015-01-01 13:23:49 +0100
commitc83f0276b3d0e58b3c2187923f481026952b113b (patch)
treec21f07eeef548b5ccec48114e1ae2ea7ad77315f /openbsc/configure.ac
parent7ff77ec713c6569715077344563ff9ab1719619c (diff)
parent8db0788896221633dbe0660d08ca03e9dcfec2b2 (diff)
Merge branch 'laforge/meas_vis'
I'm merging this code, as it is proven to be very useful. The only reason to keep it out of master was the fact that the UDP data structures it sends are non-portable, so you can only run it reliably on localhost or between identical systems (hardware/compiler/os). As this hasn't been fixed in the past >= 2 years, I am merging the code now anyway. We can still introduce a portable protocol by increasing the protocol version at a later point. There are two options: a) we make 'struct gsm_meas_rep' portable. This requires an ABI change with libosmocore, as it contains struct gsm_meas_rep_unidir :( b) we introduce a completely separate wire format with corresponding encoding and decoding functions.
Diffstat (limited to 'openbsc/configure.ac')
-rw-r--r--openbsc/configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/openbsc/configure.ac b/openbsc/configure.ac
index 69be8b632..3e5ae38a4 100644
--- a/openbsc/configure.ac
+++ b/openbsc/configure.ac
@@ -84,6 +84,10 @@ AC_HEADER_STDC
AC_CHECK_HEADERS(dahdi/user.h,,AC_MSG_WARN(DAHDI input driver will not be built))
AC_CHECK_HEADERS(dbi/dbd.h,,AC_MSG_ERROR(DBI library is not installed))
+found_cdk=yes
+AC_CHECK_HEADERS(cdk/cdk.h,,found_cdk=no)
+AM_CONDITIONAL(HAVE_LIBCDK, test "$found_cdk" = yes)
+
dnl Checks for typedefs, structures and compiler characteristics