aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/configure.ac
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2012-11-13 07:06:54 +0100
committerHarald Welte <laforge@gnumonks.org>2015-01-01 13:03:03 +0100
commit7465e4c2e19f25bad3c92288e323d4d0d9f7baf1 (patch)
tree67f31be34fc9bfe2c34a3c425cadb2536ad5f43b /openbsc/configure.ac
parent61c9156a744f48493aea3f7ff175a3ed56d154cd (diff)
build meas_vis only if libcdk is available
Diffstat (limited to 'openbsc/configure.ac')
-rw-r--r--openbsc/configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/openbsc/configure.ac b/openbsc/configure.ac
index 69be8b632..3e5ae38a4 100644
--- a/openbsc/configure.ac
+++ b/openbsc/configure.ac
@@ -84,6 +84,10 @@ AC_HEADER_STDC
AC_CHECK_HEADERS(dahdi/user.h,,AC_MSG_WARN(DAHDI input driver will not be built))
AC_CHECK_HEADERS(dbi/dbd.h,,AC_MSG_ERROR(DBI library is not installed))
+found_cdk=yes
+AC_CHECK_HEADERS(cdk/cdk.h,,found_cdk=no)
+AM_CONDITIONAL(HAVE_LIBCDK, test "$found_cdk" = yes)
+
dnl Checks for typedefs, structures and compiler characteristics