aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/configure.ac
diff options
context:
space:
mode:
authorJacob Erlbeck <jerlbeck@sysmocom.de>2013-10-15 12:00:26 +0200
committerHolger Hans Peter Freyther <holger@moiji-mobile.com>2013-10-15 15:10:22 +0200
commit51a869c80c80fbbf8494992d8c2fa10ede537029 (patch)
tree799f60fcf8def741ff15a6768c06eae63c26b2a4 /openbsc/configure.ac
parent475f513aea18be2e5d6e1d27853f4deada99697b (diff)
gbproxy: Add test program to test gbproxy message handling
This program tests the gbproxy implementation by passing NS messages to a modified gbproxy that dumps the resulting messages, signals, and state. It focusses on testing abnormal situations like port changes. Ticket: OW#874 Sponsored-by: On-Waves ehf
Diffstat (limited to 'openbsc/configure.ac')
-rw-r--r--openbsc/configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/openbsc/configure.ac b/openbsc/configure.ac
index 5c077ee39..081e416d7 100644
--- a/openbsc/configure.ac
+++ b/openbsc/configure.ac
@@ -18,6 +18,9 @@ AC_PROG_RANLIB
dnl checks for libraries
AC_SEARCH_LIBS(crypt, crypt,
[LIBCRYPT="-lcrypt"; AC_DEFINE([VTY_CRYPT_PW], [], [Use crypt functionality of vty.])])
+AC_SEARCH_LIBS([dlopen], [dl dld], [LIBRARY_DL="$LIBS";LIBS=""])
+AC_SUBST(LIBRARY_DL)
+
PKG_CHECK_MODULES(LIBOSMOCORE, libosmocore >= 0.6.4)
PKG_CHECK_MODULES(LIBOSMOVTY, libosmovty >= 0.3.0)
@@ -162,6 +165,7 @@ AC_OUTPUT(
tests/bsc-nat-trie/Makefile
tests/mgcp/Makefile
tests/gprs/Makefile
+ tests/gbproxy/Makefile
tests/si/Makefile
tests/abis/Makefile
tests/smpp/Makefile