aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/configure.ac
diff options
context:
space:
mode:
authorKaterina Barone-Adesi <kat.obsc@gmail.com>2013-04-05 17:36:09 +0200
committerHolger Hans Peter Freyther <zecke@selfish.org>2013-06-24 13:22:34 +0200
commite0aee7aaa964df27fdf6c451ea43af66c6d97b43 (patch)
tree32fb57f4c504b2c4f896c155e202961e66d2771e /openbsc/configure.ac
parentcc6b2d2fa30ad628833bf764caa8fdbac5aa1213 (diff)
Introduced support for external python tests
The test scripts warn about missing documentation, untested configs, check common errors, and stub out testing individual VTY commands. The scripts have been moved to the another osmocom repository, python/osmo-python-tests The features were requested by zecke.
Diffstat (limited to 'openbsc/configure.ac')
-rw-r--r--openbsc/configure.ac15
1 files changed, 15 insertions, 0 deletions
diff --git a/openbsc/configure.ac b/openbsc/configure.ac
index cdefcaf04..3dd22124b 100644
--- a/openbsc/configure.ac
+++ b/openbsc/configure.ac
@@ -114,6 +114,21 @@ AC_DEFUN([CHECK_TM_INCLUDES_TM_GMTOFF], [
CHECK_TM_INCLUDES_TM_GMTOFF
+AC_ARG_ENABLE([vty_tests],
+ AC_HELP_STRING([--enable-vty-tests],
+ [Include the VTY tests in make check [default=no]]),
+ [enable_vty_tests="$enableval"],[enable_vty_tests="no"])
+if test "x$enable_vty_tests" = "xyes" ; then
+ AM_PATH_PYTHON
+ AC_CHECK_PROG(OSMOTESTVTY_CHECK,osmotestvty.py,yes)
+ if test "x$OSMOTESTVTY_CHECK" != "xyes" ; then
+ AC_MSG_ERROR([Please install osmocom-python to run the vty tests.])
+ fi
+fi
+AC_MSG_CHECKING([whether to enable VTY tests])
+AC_MSG_RESULT([$enable_vty_tests])
+AM_CONDITIONAL(ENABLE_VTY_TESTS, test "x$enable_vty_tests" = "xyes")
+
dnl Generate the output
AM_CONFIG_HEADER(bscconfig.h)