aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/configure.ac
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <holger@moiji-mobile.com>2015-05-25 01:21:50 +0800
committerHolger Hans Peter Freyther <holger@moiji-mobile.com>2015-05-25 15:39:59 +0800
commit66e7106d393368b2dd0d04c08f31781ed997380b (patch)
tree7880587c0e938f181261d580798d61c501409270 /openbsc/configure.ac
parentccd2312d10e14747e8a4d26d8f72b052ffcfc282 (diff)
sgsn: Integrate c-ares with the osmocom event loop
c-ares is an asynchronous DNS resolver and we need it to resolve the GGSN address. This is integrating the library into our infrastructure. We will create and maintain a list of registered FDs (c-ares is currently only using one of them) and (re-)schedule the timer after events occurred.
Diffstat (limited to 'openbsc/configure.ac')
-rw-r--r--openbsc/configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/openbsc/configure.ac b/openbsc/configure.ac
index 394972f46..fb6feb9b9 100644
--- a/openbsc/configure.ac
+++ b/openbsc/configure.ac
@@ -79,6 +79,11 @@ PKG_CHECK_MODULES(LIBGTP, libgtp, , found_libgtp=no)
AM_CONDITIONAL(HAVE_LIBGTP, test "$found_libgtp" = yes)
AC_SUBST(found_libgtp)
+found_libcares=yes
+PKG_CHECK_MODULES([LIBCARES], [libcares], [], [found_libcares=no])
+AM_CONDITIONAL(HAVE_LIBCARES, test "$found_libcares" = yes)
+AC_SUBST(found_libcares)
+
dnl checks for header files
AC_HEADER_STDC
AC_CHECK_HEADERS(dahdi/user.h,,AC_MSG_WARN(DAHDI input driver will not be built))