aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/configure.ac
diff options
context:
space:
mode:
authorDaniel Willmann <dwillmann@sysmocom.de>2015-10-08 16:10:23 +0200
committerHolger Hans Peter Freyther <holger@moiji-mobile.com>2015-10-12 09:03:15 +0200
commitcdeb815c78f4cdd5eb38995ea3f8550c637a1561 (patch)
treeb86295be57ce68422e60e9b6837f3805f9f2070f /openbsc/configure.ac
parentb3cbd9aa3b8e80060ff38b975e297a5b4a850fec (diff)
libmsc: Use RAND_bytes when choosing a tmsi
Require openssl version to be >= 0.9.5 because we rely on the RAND_bytes return value. [hfreyther: Add cast to uint8_t*]
Diffstat (limited to 'openbsc/configure.ac')
-rw-r--r--openbsc/configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/openbsc/configure.ac b/openbsc/configure.ac
index 78302ddef..fc30b5eb2 100644
--- a/openbsc/configure.ac
+++ b/openbsc/configure.ac
@@ -27,13 +27,13 @@ PKG_CHECK_MODULES(LIBOSMOGSM, libosmogsm >= 0.7.0)
PKG_CHECK_MODULES(LIBOSMOABIS, libosmoabis >= 0.2.0)
PKG_CHECK_MODULES(LIBOSMOGB, libosmogb >= 0.6.4)
PKG_CHECK_MODULES(LIBOSMONETIF, libosmo-netif >= 0.0.1)
+PKG_CHECK_MODULES(LIBCRYPTO, libcrypto >= 0.9.5)
# Enabke/disable the NAT?
AC_ARG_ENABLE([nat], [AS_HELP_STRING([--enable-nat], [Build the BSC NAT. Requires SCCP])],
[osmo_ac_build_nat="$enableval"],[osmo_ac_build_nat="no"])
if test "$osmo_ac_build_nat" = "yes" ; then
PKG_CHECK_MODULES(LIBOSMOSCCP, libosmo-sccp >= 0.0.2)
- PKG_CHECK_MODULES(LIBCRYPTO, libcrypto)
fi
AM_CONDITIONAL(BUILD_NAT, test "x$osmo_ac_build_nat" = "xyes")
AC_SUBST(osmo_ac_build_nat)