aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/configure.ac
diff options
context:
space:
mode:
authorNeels Hofmeyr <nhofmeyr@sysmocom.de>2016-06-15 14:43:20 +0200
committerHarald Welte <laforge@gnumonks.org>2016-06-17 15:33:22 +0000
commitf8e02aa4e3d87bbdc66819d3a56380881e24ce5a (patch)
tree46f857f982fe53d2a82462f7cdfbe55ea967da8c /openbsc/configure.ac
parent349108801fb8d0eb23dc11da6a38ab94529ba341 (diff)
configure: require libgsm for --enable-mgcp-transcoding
Fail in configure if libgsm is not found. Before this, the --enable-mgcp-transcoding would gladly accept that libgsm is missing and the build would fail later because of missing linking and undefined references. Change-Id: Ic23157cc5b75694f400a176c31f97d71e861ea02
Diffstat (limited to 'openbsc/configure.ac')
-rw-r--r--openbsc/configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/openbsc/configure.ac b/openbsc/configure.ac
index 5cd5d2d80..09804135f 100644
--- a/openbsc/configure.ac
+++ b/openbsc/configure.ac
@@ -63,7 +63,7 @@ AC_ARG_ENABLE([mgcp-transcoding], [AS_HELP_STRING([--enable-mgcp-transcoding], [
AC_ARG_WITH([g729], [AS_HELP_STRING([--with-g729], [Enable G.729 encoding/decoding.])], [osmo_ac_with_g729="$withval"],[osmo_ac_with_g729="no"])
if test "$osmo_ac_mgcp_transcoding" = "yes" ; then
- AC_SEARCH_LIBS([gsm_create], [gsm], [LIBRARY_GSM="$LIBS";LIBS=""])
+ AC_SEARCH_LIBS([gsm_create], [gsm], [LIBRARY_GSM="$LIBS";LIBS=""], [AC_MSG_ERROR([--enable-mgcp-transcoding: cannot find usable libgsm])])
AC_SUBST(LIBRARY_GSM)
if test "$osmo_ac_with_g729" = "yes" ; then
PKG_CHECK_MODULES(LIBBCG729, libbcg729 >= 0.1, [AC_DEFINE([HAVE_BCG729], [1], [Use bgc729 decoder/encoder])])