aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/configure.ac
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <holger@moiji-mobile.com>2014-08-22 00:29:04 +0200
committerHolger Hans Peter Freyther <holger@moiji-mobile.com>2014-08-22 00:29:04 +0200
commitdd588ae2ceb573faebef28bdab471251700796da (patch)
tree024858db61e2d9965dc4c0566c410bceddb71ea6 /openbsc/configure.ac
parent29805da6d17f367495d0d0d94098a07b01ea53e2 (diff)
misc: Introduce a more neutral configure option for CTRL/VTY
We started with only testing the VTY but now test VTY and CTRL interface with this python framework and might even extend this to SMPP. So add and "--enable-external-tests" directive which enables the external interface tests.
Diffstat (limited to 'openbsc/configure.ac')
-rw-r--r--openbsc/configure.ac23
1 files changed, 14 insertions, 9 deletions
diff --git a/openbsc/configure.ac b/openbsc/configure.ac
index 7c1803cd0..0777c0de2 100644
--- a/openbsc/configure.ac
+++ b/openbsc/configure.ac
@@ -138,18 +138,23 @@ CHECK_TM_INCLUDES_TM_GMTOFF
AC_ARG_ENABLE([vty_tests],
AC_HELP_STRING([--enable-vty-tests],
- [Include the VTY tests in make check [default=no]]),
- [enable_vty_tests="$enableval"],[enable_vty_tests="no"])
-if test "x$enable_vty_tests" = "xyes" ; then
+ [Include the VTY/CTRL tests in make check (deprecated)
+ [default=no]]),
+ [enable_ext_tests="$enableval"],[enable_ext_tests="no"])
+AC_ARG_ENABLE([ext_tests],
+ AC_HELP_STRING([--enable-external-tests],
+ [Include the VTY/CTRL tests in make check [default=no]]),
+ [enable_ext_tests="$enableval"],[enable_ext_tests="no"])
+if test "x$enable_ext_tests" = "xyes" ; then
AM_PATH_PYTHON
- AC_CHECK_PROG(OSMOTESTVTY_CHECK,osmotestvty.py,yes)
- if test "x$OSMOTESTVTY_CHECK" != "xyes" ; then
- AC_MSG_ERROR([Please install osmocom-python to run the vty tests.])
+ AC_CHECK_PROG(OSMOTESTEXT_CHECK,osmotestvty.py,yes)
+ if test "x$OSMOTESTEXT_CHECK" != "xyes" ; then
+ AC_MSG_ERROR([Please install osmocom-python to run the VTY/CTRL tests.])
fi
fi
-AC_MSG_CHECKING([whether to enable VTY tests])
-AC_MSG_RESULT([$enable_vty_tests])
-AM_CONDITIONAL(ENABLE_VTY_TESTS, test "x$enable_vty_tests" = "xyes")
+AC_MSG_CHECKING([whether to enable VTY/CTRL tests])
+AC_MSG_RESULT([$enable_ext_tests])
+AM_CONDITIONAL(ENABLE_EXT_TESTS, test "x$enable_ext_tests" = "xyes")
dnl Generate the output
AM_CONFIG_HEADER(bscconfig.h)