aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/configure.ac
diff options
context:
space:
mode:
authorNeels Hofmeyr <nhofmeyr@sysmocom.de>2017-02-15 00:20:44 +0100
committerNeels Hofmeyr <nhofmeyr@sysmocom.de>2017-03-16 15:32:29 +0100
commitac5f9276c443c01f0cf1f4dc6d04ba1d2b09d422 (patch)
treee2b2968a590833d802adb487c54ace16862eee0a /openbsc/configure.ac
parentd36144d6c98bfcf4db106a4596f4238524ec3eab (diff)
vlr: get SMS working, by SMS recipient MSISDN round-robin
The SQL based lookup of SMS for attached subscribers no longer works since the SQL database no longer has the subscriber data. Replace with a round-robin on the SMS recipient MSISDNs paired with a VLR subscriber RAM lookup whether the subscriber is currently attached. If there are many SMS for not-attached subscribers in the SMS database, this will become inefficient: a DB hit returns a pending SMS, the RAM lookup will reveal that the subscriber is not attached, after which the DB is hit for the next SMS. It would become more efficient e.g. by having an MSISDN based hash list for the VLR subscribers and by marking non-attached SMS recipients in the SMS database so that they can be excluded with the SQL query already. There is a sanity limit to do at most 100 db hits per attempt to find a pending SMS. So if there are more than 100 stored SMS waiting for their recipients to actually attach to the MSC, it may take more than one SMS queue trigger to deliver SMS for subscribers that are actually attached. This is not very beautiful, but is merely intended to carry us over to a time when we have a proper separate SMSC entity. Change-Id: I1acf9debb6ba9164e6edcfd5bc5e48e8c98f2b01
Diffstat (limited to 'openbsc/configure.ac')
-rw-r--r--openbsc/configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/openbsc/configure.ac b/openbsc/configure.ac
index 0da7c9c21..0ba73b911 100644
--- a/openbsc/configure.ac
+++ b/openbsc/configure.ac
@@ -260,6 +260,7 @@ AC_OUTPUT(
tests/nanobts_omlattr/Makefile
tests/vlr/Makefile
tests/msc_vlr/Makefile
+ tests/sms_queue/Makefile
doc/Makefile
doc/examples/Makefile
Makefile)