aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/configure.ac
diff options
context:
space:
mode:
authorSergey.Kostanbaev <Sergey.Kostanbaev@gmail.com>2016-02-09 20:21:08 +0300
committerIvan Kluchnikov <kluchnikovi@gmail.com>2017-02-07 18:59:54 +0300
commitd4839fe14a0d060933f0006d10dc932375a7c7d6 (patch)
treea640aa5741fa5f75646e6b3e779957639eb8294e /openbsc/configure.ac
parentdb0e216845a7859bf878a891e2a210dbef6395df (diff)
manual merge SS from sup-ussd-on-master-ss-wip
Diffstat (limited to 'openbsc/configure.ac')
-rw-r--r--openbsc/configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/openbsc/configure.ac b/openbsc/configure.ac
index c31d36eaf..179e56f97 100644
--- a/openbsc/configure.ac
+++ b/openbsc/configure.ac
@@ -211,6 +211,18 @@ AC_MSG_CHECKING([whether to enable VTY/CTRL tests])
AC_MSG_RESULT([$enable_ext_tests])
AM_CONDITIONAL(ENABLE_EXT_TESTS, test "x$enable_ext_tests" = "xyes")
+
+# Enable/disable ussd_proxy utility
+AC_ARG_ENABLE([ussd_proxy], [AS_HELP_STRING([--enable-ussd-proxy], [Build the USSD MAP SUP to SIP proxy])],
+ [osmo_ac_build_ussd_proxy="$enableval"],[osmo_ac_build_ussd_proxy="no"])
+if test "$osmo_ac_build_ussd_proxy" = "yes" ; then
+ PKG_CHECK_MODULES(LIBSOFIA_SIP_UA, sofia-sip-ua >= 1.10)
+ AC_DEFINE(BUILD_USSD_PROXY, 1, [Define if we want to build ussd_proxy])
+fi
+AM_CONDITIONAL(BUILD_USSD_PROXY, test "x$osmo_ac_build_ussd_proxy" = "xyes")
+AC_SUBST(osmo_ac_build_smpp)
+
+
dnl Generate the output
AM_CONFIG_HEADER(bscconfig.h)
@@ -259,6 +271,7 @@ AC_OUTPUT(
tests/slhc/Makefile
tests/v42bis/Makefile
tests/nanobts_omlattr/Makefile
+ tests/ussd/Makefile
doc/Makefile
doc/examples/Makefile
Makefile)