aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/configure.ac
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <holger@moiji-mobile.com>2015-07-02 09:51:31 +0200
committerHolger Hans Peter Freyther <holger@moiji-mobile.com>2015-07-02 09:51:31 +0200
commitb69518f3834b60901ab5750b6ce3b623d9479c1e (patch)
treea6954e4ec04db4c001ab930e15344779fa2208ac /openbsc/configure.ac
parent58ec15c4edd14914479f2c4a6a885a6435dc81fe (diff)
configure: Do not link all applications against libgsm
Use the same trick as done by the dlopen check to not have everyone link against the library.
Diffstat (limited to 'openbsc/configure.ac')
-rw-r--r--openbsc/configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/openbsc/configure.ac b/openbsc/configure.ac
index 0932f4226..0ebb041fa 100644
--- a/openbsc/configure.ac
+++ b/openbsc/configure.ac
@@ -63,7 +63,8 @@ AC_ARG_ENABLE([mgcp-transcoding], [AS_HELP_STRING([--enable-mgcp-transcoding], [
AC_ARG_WITH([g729], [AS_HELP_STRING([--with-g729], [Enable G.729 encoding/decoding.])], [osmo_ac_with_g729="$withval"],[osmo_ac_with_g729="no"])
if test "$osmo_ac_mgcp_transcoding" = "yes" ; then
- AC_SEARCH_LIBS(gsm_create, gsm)
+ AC_SEARCH_LIBS([gsm_create], [gsm], [LIBRARY_GSM="$LIBS";LIBS=""])
+ AC_SUBST(LIBRARY_GSM)
if test "$osmo_ac_with_g729" = "yes" ; then
PKG_CHECK_MODULES(LIBBCG729, libbcg729 >= 0.1, [AC_DEFINE([HAVE_BCG729], [1], [Use bgc729 decoder/encoder])])
fi