aboutsummaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <holger@moiji-mobile.com>2013-12-12 13:07:47 +0100
committerHolger Hans Peter Freyther <holger@moiji-mobile.com>2013-12-12 13:08:26 +0100
commit65f7427e025dd1962dcab2214453a66a639cf231 (patch)
tree45635852d5729ddbb4e5a9fb149708bbb5fa8d0a /debian/rules
parent9f4f4e6c293b7956da5cdf795305de6c49bb4c8a (diff)
debian: Build debug packages for each of the target packages
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules9
1 files changed, 9 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index 89f96ccb8..586fa1098 100755
--- a/debian/rules
+++ b/debian/rules
@@ -24,6 +24,15 @@ VERSION := $(shell echo '$(DEBVERS)' | sed -e 's/[+-].*//' -e 's/~//g')
override_dh_autoreconf:
cd openbsc && autoreconf --install --force
+override_dh_strip:
+ dh_strip -posmocom-bsc --dbg-package=osmocom-bsc-dbg
+ dh_strip -posmocom-nitb --dbg-package=osmocom-nitb-dbg
+ dh_strip -posmocom-ipaccess-utils --dbg-package=osmocom-ipaccess-utils-dbg
+ dh_strip -posmocom-bs11-utils --dbg-package=osmocom-bs11-utils-dbg
+ dh_strip -posmocom-sgsn --dbg-package=osmocom-sgsn-dbg
+ dh_strip -posmocom-gbproxy --dbg-package=osmocom-gbproxy-dbg
+ dh_strip -posmocom-bsc-nat --dbg-package=osmocom-bsc-nat-dbg
+
override_dh_auto_configure:
echo $(VERSION) > openbsc/.tarball-version
dh_auto_configure --sourcedirectory=openbsc -- --enable-nat --enable-osmo-bsc