aboutsummaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <zecke@selfish.org>2012-11-06 19:26:50 +0100
committerHolger Hans Peter Freyther <zecke@selfish.org>2012-11-06 23:12:02 +0100
commit93fda87cf88be8508a1075b9995d9efe0088b4c0 (patch)
treeb65e2842f13fc07218dd4eb029a407d0d06bd8b7 /debian/rules
parente0b5972d301fc353c522537ca8064e4c5b77beb9 (diff)
debian: Make the package creation work on debian squeeze (stable)
the dh_autoreconf application did not honor the sourcedirectory option back then. Override the target and call autoreconf from the right directory. The libdbi development package is called libdbi0-dev. Use this name for Debian stable but it should work for Ubuntu as well.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules4
1 files changed, 4 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index cac108d1e..89f96ccb8 100755
--- a/debian/rules
+++ b/debian/rules
@@ -20,6 +20,10 @@ VERSION := $(shell echo '$(DEBVERS)' | sed -e 's/[+-].*//' -e 's/~//g')
%:
dh --sourcedirectory=openbsc --with autoreconf $@
+# This is needed for debian stable (squeeze)
+override_dh_autoreconf:
+ cd openbsc && autoreconf --install --force
+
override_dh_auto_configure:
echo $(VERSION) > openbsc/.tarball-version
dh_auto_configure --sourcedirectory=openbsc -- --enable-nat --enable-osmo-bsc