aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-isdn/libgsm/files/0001-Configure-Makefile.patch (renamed from recipes-isdn/libgsm/libgsm-1.0.13/01_makefile.patch)34
-rw-r--r--recipes-isdn/libgsm/files/0002-Add-defines-to-c.patch39
-rw-r--r--recipes-isdn/libgsm/files/0003-Use-gsm_config.-header-instead-of-config.h.patch (renamed from recipes-isdn/libgsm/libgsm-1.0.13/03_config.patch)84
-rw-r--r--recipes-isdn/libgsm/files/0004-Add-includes.patch41
-rw-r--r--recipes-isdn/libgsm/files/0005-Change-compiler-warnings.patch (renamed from recipes-isdn/libgsm/libgsm-1.0.13/05_compiler_warnings.patch)46
-rw-r--r--recipes-isdn/libgsm/libgsm-1.0.13/02_cplusplus.patch25
-rw-r--r--recipes-isdn/libgsm/libgsm-1.0.13/04_includes.patch43
-rw-r--r--recipes-isdn/libgsm/libgsm_1.0.14.bb (renamed from recipes-isdn/libgsm/libgsm_1.0.13.bb)18
8 files changed, 202 insertions, 128 deletions
diff --git a/recipes-isdn/libgsm/libgsm-1.0.13/01_makefile.patch b/recipes-isdn/libgsm/files/0001-Configure-Makefile.patch
index 947db37..60aa78d 100644
--- a/recipes-isdn/libgsm/libgsm-1.0.13/01_makefile.patch
+++ b/recipes-isdn/libgsm/files/0001-Configure-Makefile.patch
@@ -1,7 +1,18 @@
-diff -urNad libgsm-1.0.12~/Makefile libgsm-1.0.12/Makefile
---- libgsm-1.0.12~/Makefile 2007-11-01 15:37:52.000000000 +0100
-+++ libgsm-1.0.12/Makefile 2007-11-01 15:43:06.000000000 +0100
-@@ -96,7 +96,7 @@
+Upstream-Status: Inappropriate [configuration]
+
+Subject: [PATCH 1/5] Configure Makefile
+Organization: O.S. Systems Software LTDA.
+
+Signed-off-by: Fabio Berton <fabio.berton@ossystems.com.br>
+---
+ Makefile | 20 ++++++++++++++------
+ 1 file changed, 14 insertions(+), 6 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index cfab74f..410d3f6 100644
+--- a/Makefile
++++ b/Makefile
+@@ -96,7 +96,7 @@ TOAST_INSTALL_MAN = $(TOAST_INSTALL_ROOT)/man/man1
# Other tools
SHELL = /bin/sh
@@ -10,15 +21,15 @@ diff -urNad libgsm-1.0.12~/Makefile libgsm-1.0.12/Makefile
BASENAME = basename
AR = ar
ARFLAGS = cr
-@@ -140,6 +140,7 @@
+@@ -140,6 +140,7 @@ LFLAGS = $(LDFLAGS) $(LDINC)
# Targets
LIBGSM = $(LIB)/libgsm.a
-+LIBGSMSO= $(LIB)/libgsm.so
++LIBGSMSO = $(LIB)/libgsm.so
TOAST = $(BIN)/toast
UNTOAST = $(BIN)/untoast
-@@ -279,7 +280,7 @@
+@@ -279,7 +280,7 @@ TOAST_INSTALL_TARGETS = \
# Target rules
@@ -27,7 +38,7 @@ diff -urNad libgsm-1.0.12~/Makefile libgsm-1.0.12/Makefile
@-echo $(ROOT): Done.
tst: $(TST)/lin2cod $(TST)/cod2lin $(TOAST) $(TST)/test-result
-@@ -299,6 +300,11 @@
+@@ -299,6 +300,11 @@ install: toastinstall gsminstall
# The basic API: libgsm
@@ -39,7 +50,7 @@ diff -urNad libgsm-1.0.12~/Makefile libgsm-1.0.12/Makefile
$(LIBGSM): $(LIB) $(GSM_OBJECTS)
-rm $(RMFLAGS) $(LIBGSM)
$(AR) $(ARFLAGS) $(LIBGSM) $(GSM_OBJECTS)
-@@ -308,15 +314,15 @@
+@@ -308,15 +314,15 @@ $(LIBGSM): $(LIB) $(GSM_OBJECTS)
# Toast, Untoast and Tcat -- the compress-like frontends to gsm.
$(TOAST): $(BIN) $(TOAST_OBJECTS) $(LIBGSM)
@@ -58,7 +69,7 @@ diff -urNad libgsm-1.0.12~/Makefile libgsm-1.0.12/Makefile
# The local bin and lib directories
-@@ -426,7 +432,9 @@
+@@ -426,7 +432,9 @@ semi-clean:
clean: semi-clean
-rm $(RMFLAGS) $(LIBGSM) $(ADDTST)/add \
@@ -69,3 +80,6 @@ diff -urNad libgsm-1.0.12~/Makefile libgsm-1.0.12/Makefile
$(ROOT)/gsm-1.0.tar.Z
+--
+2.1.4
+
diff --git a/recipes-isdn/libgsm/files/0002-Add-defines-to-c.patch b/recipes-isdn/libgsm/files/0002-Add-defines-to-c.patch
new file mode 100644
index 0000000..70f34f2
--- /dev/null
+++ b/recipes-isdn/libgsm/files/0002-Add-defines-to-c.patch
@@ -0,0 +1,39 @@
+Upstream-Status: Inappropriate [configuration]
+
+Subject: [PATCH 2/5] Add defines to c++
+Organization: O.S. Systems Software LTDA.
+
+Signed-off-by: Fabio Berton <fabio.berton@ossystems.com.br>
+---
+ inc/gsm.h | 8 ++++++++
+ 1 file changed, 8 insertions(+)
+
+diff --git a/inc/gsm.h b/inc/gsm.h
+index 4714ab6..eb2d5e7 100644
+--- a/inc/gsm.h
++++ b/inc/gsm.h
+@@ -54,6 +54,10 @@ typedef gsm_byte gsm_frame[33]; /* 33 * 8 bits */
+ #define GSM_OPT_FRAME_INDEX 5
+ #define GSM_OPT_FRAME_CHAIN 6
+
++#ifdef __cplusplus
++extern "C" {
++#endif
++
+ extern gsm gsm_create GSM_P((void));
+ extern void gsm_destroy GSM_P((gsm));
+
+@@ -66,6 +70,10 @@ extern int gsm_decode GSM_P((gsm, gsm_byte *, gsm_signal *));
+ extern int gsm_explode GSM_P((gsm, gsm_byte *, gsm_signal *));
+ extern void gsm_implode GSM_P((gsm, gsm_signal *, gsm_byte *));
+
++#ifdef __cplusplus
++}
++#endif
++
+ #undef GSM_P
+
+ #endif /* GSM_H */
+--
+2.1.4
+
diff --git a/recipes-isdn/libgsm/libgsm-1.0.13/03_config.patch b/recipes-isdn/libgsm/files/0003-Use-gsm_config.-header-instead-of-config.h.patch
index dad241e..6755124 100644
--- a/recipes-isdn/libgsm/libgsm-1.0.13/03_config.patch
+++ b/recipes-isdn/libgsm/files/0003-Use-gsm_config.-header-instead-of-config.h.patch
@@ -1,7 +1,27 @@
-diff -urNad libgsm-1.0.10~/Makefile libgsm-1.0.10/Makefile
---- libgsm-1.0.10~/Makefile 2007-11-01 15:37:52.000000000 +0100
-+++ libgsm-1.0.10/Makefile 2007-11-01 15:48:02.000000000 +0100
-@@ -151,7 +151,7 @@
+Upstream-Status: Inappropriate [configuration]
+
+Subject: [PATCH 3/5] Use gsm_config. header instead of config.h
+Organization: O.S. Systems Software LTDA.
+
+Signed-off-by: Fabio Berton <fabio.berton@ossystems.com.br>
+---
+ Makefile | 2 +-
+ inc/config.h | 37 -------------------------------------
+ inc/gsm_config.h | 37 +++++++++++++++++++++++++++++++++++++
+ inc/toast.h | 2 +-
+ src/code.c | 2 +-
+ src/gsm_create.c | 2 +-
+ src/gsm_destroy.c | 2 +-
+ tls/taste.c | 2 +-
+ 8 files changed, 43 insertions(+), 43 deletions(-)
+ delete mode 100644 inc/config.h
+ create mode 100644 inc/gsm_config.h
+
+diff --git a/Makefile b/Makefile
+index 410d3f6..c8c5b58 100644
+--- a/Makefile
++++ b/Makefile
+@@ -152,7 +152,7 @@ GSM_HEADERS = $(INC)/gsm.h
HEADERS = $(INC)/proto.h \
$(INC)/unproto.h \
@@ -10,9 +30,11 @@ diff -urNad libgsm-1.0.10~/Makefile libgsm-1.0.10/Makefile
$(INC)/private.h \
$(INC)/gsm.h \
$(INC)/toast.h \
-diff -urNad libgsm-1.0.10~/inc/config.h libgsm-1.0.10/inc/config.h
---- libgsm-1.0.10~/inc/config.h 2007-11-01 15:37:52.000000000 +0100
-+++ libgsm-1.0.10/inc/config.h 1970-01-01 01:00:00.000000000 +0100
+diff --git a/inc/config.h b/inc/config.h
+deleted file mode 100644
+index dfb1ead..0000000
+--- a/inc/config.h
++++ /dev/null
@@ -1,37 +0,0 @@
-/*
- * Copyright 1992 by Jutta Degener and Carsten Bormann, Technische
@@ -51,9 +73,11 @@ diff -urNad libgsm-1.0.10~/inc/config.h libgsm-1.0.10/inc/config.h
-/*efine HAS_UTIMEUSEC 1 /* microseconds in utimbuf? */
-
-#endif /* CONFIG_H */
-diff -urNad libgsm-1.0.10~/inc/gsm_config.h libgsm-1.0.10/inc/gsm_config.h
---- libgsm-1.0.10~/inc/gsm_config.h 1970-01-01 01:00:00.000000000 +0100
-+++ libgsm-1.0.10/inc/gsm_config.h 2007-11-01 15:46:19.000000000 +0100
+diff --git a/inc/gsm_config.h b/inc/gsm_config.h
+new file mode 100644
+index 0000000..28cee6d
+--- /dev/null
++++ b/inc/gsm_config.h
@@ -0,0 +1,37 @@
+/*
+ * Copyright 1992 by Jutta Degener and Carsten Bormann, Technische
@@ -92,9 +116,10 @@ diff -urNad libgsm-1.0.10~/inc/gsm_config.h libgsm-1.0.10/inc/gsm_config.h
+/*efine HAS_UTIMEUSEC 1 -* microseconds in utimbuf? */
+
+#endif /* CONFIG_H */
-diff -urNad libgsm-1.0.10~/inc/toast.h libgsm-1.0.10/inc/toast.h
---- libgsm-1.0.10~/inc/toast.h 2007-11-01 15:37:52.000000000 +0100
-+++ libgsm-1.0.10/inc/toast.h 2007-11-01 15:48:17.000000000 +0100
+diff --git a/inc/toast.h b/inc/toast.h
+index b42d9ae..911769d 100644
+--- a/inc/toast.h
++++ b/inc/toast.h
@@ -9,7 +9,7 @@
#ifndef TOAST_H
#define TOAST_H /* Guard against multiple includes */
@@ -104,9 +129,10 @@ diff -urNad libgsm-1.0.10~/inc/toast.h libgsm-1.0.10/inc/toast.h
#include <sys/types.h>
#include <sys/stat.h>
-diff -urNad libgsm-1.0.10~/src/code.c libgsm-1.0.10/src/code.c
---- libgsm-1.0.10~/src/code.c 2007-11-01 15:37:52.000000000 +0100
-+++ libgsm-1.0.10/src/code.c 2007-11-01 15:48:34.000000000 +0100
+diff --git a/src/code.c b/src/code.c
+index 402f614..5222727 100644
+--- a/src/code.c
++++ b/src/code.c
@@ -6,7 +6,7 @@
/* $Header: /tmp_amd/presto/export/kbs/jutta/src/gsm/RCS/code.c,v 1.3 1996/07/02 09:59:05 jutta Exp $ */
@@ -115,10 +141,11 @@ diff -urNad libgsm-1.0.10~/src/code.c libgsm-1.0.10/src/code.c
+#include "gsm_config.h"
- #ifdef HAS_STDLIB_H
-diff -urNad libgsm-1.0.10~/src/gsm_create.c libgsm-1.0.10/src/gsm_create.c
---- libgsm-1.0.10~/src/gsm_create.c 1996-07-02 16:32:44.000000000 +0200
-+++ libgsm-1.0.10/src/gsm_create.c 2007-11-01 15:48:48.000000000 +0100
+ #ifdef HAS_STRING_H
+diff --git a/src/gsm_create.c b/src/gsm_create.c
+index a0bf634..9cc2670 100644
+--- a/src/gsm_create.c
++++ b/src/gsm_create.c
@@ -6,7 +6,7 @@
static char const ident[] = "$Header: /tmp_amd/presto/export/kbs/jutta/src/gsm/RCS/gsm_create.c,v 1.4 1996/07/02 09:59:05 jutta Exp $";
@@ -128,9 +155,10 @@ diff -urNad libgsm-1.0.10~/src/gsm_create.c libgsm-1.0.10/src/gsm_create.c
#ifdef HAS_STRING_H
#include <string.h>
-diff -urNad libgsm-1.0.10~/src/gsm_destroy.c libgsm-1.0.10/src/gsm_destroy.c
---- libgsm-1.0.10~/src/gsm_destroy.c 1996-07-02 16:32:39.000000000 +0200
-+++ libgsm-1.0.10/src/gsm_destroy.c 2007-11-01 15:48:57.000000000 +0100
+diff --git a/src/gsm_destroy.c b/src/gsm_destroy.c
+index 03c8659..274dc4c 100644
+--- a/src/gsm_destroy.c
++++ b/src/gsm_destroy.c
@@ -7,7 +7,7 @@
/* $Header: /tmp_amd/presto/export/kbs/jutta/src/gsm/RCS/gsm_destroy.c,v 1.3 1994/11/28 19:52:25 jutta Exp $ */
@@ -140,9 +168,10 @@ diff -urNad libgsm-1.0.10~/src/gsm_destroy.c libgsm-1.0.10/src/gsm_destroy.c
#include "proto.h"
#ifdef HAS_STDLIB_H
-diff -urNad libgsm-1.0.10~/tls/taste.c libgsm-1.0.10/tls/taste.c
---- libgsm-1.0.10~/tls/taste.c 1996-07-02 16:33:05.000000000 +0200
-+++ libgsm-1.0.10/tls/taste.c 2007-11-01 15:49:54.000000000 +0100
+diff --git a/tls/taste.c b/tls/taste.c
+index 4bc84ad..56d1a93 100644
+--- a/tls/taste.c
++++ b/tls/taste.c
@@ -10,7 +10,7 @@
#include <string.h>
#include <memory.h>
@@ -152,3 +181,6 @@ diff -urNad libgsm-1.0.10~/tls/taste.c libgsm-1.0.10/tls/taste.c
#ifdef HAS_STDLIB_H
# include <stdlib.h>
+--
+2.1.4
+
diff --git a/recipes-isdn/libgsm/files/0004-Add-includes.patch b/recipes-isdn/libgsm/files/0004-Add-includes.patch
new file mode 100644
index 0000000..efb1133
--- /dev/null
+++ b/recipes-isdn/libgsm/files/0004-Add-includes.patch
@@ -0,0 +1,41 @@
+Upstream-Status: Inappropriate [configuration]
+
+Subject: [PATCH 4/5] Add includes
+Organization: O.S. Systems Software LTDA.
+
+Signed-off-by: Fabio Berton <fabio.berton@ossystems.com.br>
+---
+ inc/toast.h | 7 ++++++-
+ 1 file changed, 6 insertions(+), 1 deletion(-)
+
+diff --git a/inc/toast.h b/inc/toast.h
+index 911769d..3e710d0 100644
+--- a/inc/toast.h
++++ b/inc/toast.h
+@@ -16,10 +16,11 @@
+
+ #include <stdio.h>
+ #include <ctype.h>
++#include <pthread.h>
+ #include <signal.h>
+
+ #include <errno.h>
+-#ifndef HAS_ERRNO_DECL
++#ifndef errno
+ extern int errno;
+ #endif
+
+@@ -37,6 +38,10 @@
+ # endif
+ #endif
+
++#ifdef HAS_STDIO_H
++# include <stdio.h>
++#endif
++
+ #include "gsm.h"
+
+ #ifndef S_ISREG
+--
+2.1.4
+
diff --git a/recipes-isdn/libgsm/libgsm-1.0.13/05_compiler_warnings.patch b/recipes-isdn/libgsm/files/0005-Change-compiler-warnings.patch
index c40100c..126d4ff 100644
--- a/recipes-isdn/libgsm/libgsm-1.0.13/05_compiler_warnings.patch
+++ b/recipes-isdn/libgsm/files/0005-Change-compiler-warnings.patch
@@ -1,7 +1,19 @@
-diff -urNad libgsm-1.0.10~/src/debug.c libgsm-1.0.10/src/debug.c
---- libgsm-1.0.10~/src/debug.c 2007-11-01 15:37:52.000000000 +0100
-+++ libgsm-1.0.10/src/debug.c 2007-11-01 15:53:42.000000000 +0100
-@@ -49,7 +49,7 @@
+Upstream-Status: Inappropriate [configuration]
+
+Subject: [PATCH 5/5] Change compiler warnings
+Organization: O.S. Systems Software LTDA.
+
+Signed-off-by: Fabio Berton <fabio.berton@ossystems.com.br>
+---
+ src/debug.c | 6 +++---
+ src/toast.c | 17 +++++++----------
+ 2 files changed, 10 insertions(+), 13 deletions(-)
+
+diff --git a/src/debug.c b/src/debug.c
+index 04c3907..a2a5136 100644
+--- a/src/debug.c
++++ b/src/debug.c
+@@ -49,7 +49,7 @@ void gsm_debug_longwords P4( (name, from, to, ptr),
fprintf( stderr, "%s [%d .. %d]: ", name, from, to );
while (from <= to) {
@@ -10,7 +22,7 @@ diff -urNad libgsm-1.0.10~/src/debug.c libgsm-1.0.10/src/debug.c
from++;
if (nprinted++ >= 7) {
nprinted = 0;
-@@ -63,14 +63,14 @@
+@@ -63,14 +63,14 @@ void gsm_debug_longword P2( (name, value),
char * name,
longword value )
{
@@ -27,10 +39,11 @@ diff -urNad libgsm-1.0.10~/src/debug.c libgsm-1.0.10/src/debug.c
}
#endif
-diff -urNad libgsm-1.0.10~/src/toast.c libgsm-1.0.10/src/toast.c
---- libgsm-1.0.10~/src/toast.c 2007-11-01 15:37:52.000000000 +0100
-+++ libgsm-1.0.10/src/toast.c 2007-11-01 15:53:42.000000000 +0100
-@@ -251,8 +251,8 @@
+diff --git a/src/toast.c b/src/toast.c
+index 9823642..55606d7 100644
+--- a/src/toast.c
++++ b/src/toast.c
+@@ -251,8 +251,8 @@ static char * emalloc P1((len), size_t len)
{
char * s;
if (!(s = malloc(len))) {
@@ -41,7 +54,7 @@ diff -urNad libgsm-1.0.10~/src/toast.c libgsm-1.0.10/src/toast.c
onintr();
exit(1);
}
-@@ -270,7 +270,7 @@
+@@ -270,7 +270,7 @@ static char* normalname P3((name, want, cut), char *name, char *want,char *cut)
maxlen = strlen(name) + 1 + strlen(want) + strlen(cut);
p = strcpy(emalloc(maxlen), name);
@@ -50,7 +63,7 @@ diff -urNad libgsm-1.0.10~/src/toast.c libgsm-1.0.10/src/toast.c
else if (*want && !suffix(p, want)) strcat(p, want);
return p;
-@@ -386,7 +386,7 @@
+@@ -386,7 +386,7 @@ static void update_times P0()
ut[0] = instat.st_atime;
ut[1] = instat.st_mtime;
@@ -59,7 +72,7 @@ diff -urNad libgsm-1.0.10~/src/toast.c libgsm-1.0.10/src/toast.c
#endif /* UTIMBUF */
}
-@@ -416,7 +416,7 @@
+@@ -416,7 +416,7 @@ static int okay_as_input P3((name,f,st), char* name, FILE* f, struct stat * st)
}
if (st->st_nlink > 1 && !f_cat && !f_precious) {
fprintf(stderr,
@@ -68,7 +81,7 @@ diff -urNad libgsm-1.0.10~/src/toast.c libgsm-1.0.10/src/toast.c
progname,name,st->st_nlink - 1,"s" + (st->st_nlink<=2));
return 0;
}
-@@ -585,8 +585,8 @@
+@@ -585,8 +585,8 @@ static int process_decode P0()
if (cc != sizeof(s)) {
if (cc >= 0) fprintf(stderr,
@@ -79,7 +92,7 @@ diff -urNad libgsm-1.0.10~/src/toast.c libgsm-1.0.10/src/toast.c
"s" + (sizeof(s) - cc == 1),
inname ? inname : "stdin" );
gsm_destroy(r);
-@@ -624,8 +624,6 @@
+@@ -624,8 +624,6 @@ static int process_decode P0()
static int process P1((name), char * name)
{
@@ -88,7 +101,7 @@ diff -urNad libgsm-1.0.10~/src/toast.c libgsm-1.0.10/src/toast.c
out = (FILE *)0;
in = (FILE *)0;
-@@ -779,7 +777,6 @@
+@@ -779,7 +777,6 @@ int main P2((ac, av), int ac, char **av)
case 'h': help(); exit(0);
default:
@@ -96,3 +109,6 @@ diff -urNad libgsm-1.0.10~/src/toast.c libgsm-1.0.10/src/toast.c
fprintf(stderr,
"Usage: %s [-fcpdhvuaslFC] [files...] (-h for help)\n",
progname);
+--
+2.1.4
+
diff --git a/recipes-isdn/libgsm/libgsm-1.0.13/02_cplusplus.patch b/recipes-isdn/libgsm/libgsm-1.0.13/02_cplusplus.patch
deleted file mode 100644
index a4bbb40..0000000
--- a/recipes-isdn/libgsm/libgsm-1.0.13/02_cplusplus.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-diff -urNad libgsm-1.0.10~/inc/gsm.h libgsm-1.0.10/inc/gsm.h
---- libgsm-1.0.10~/inc/gsm.h 2007-11-01 15:37:52.000000000 +0100
-+++ libgsm-1.0.10/inc/gsm.h 2007-11-01 15:44:52.000000000 +0100
-@@ -54,6 +54,10 @@
- #define GSM_OPT_FRAME_INDEX 5
- #define GSM_OPT_FRAME_CHAIN 6
-
-+#ifdef __cplusplus
-+extern "C" {
-+#endif
-+
- extern gsm gsm_create GSM_P((void));
- extern void gsm_destroy GSM_P((gsm));
-
-@@ -66,6 +70,10 @@
- extern int gsm_explode GSM_P((gsm, gsm_byte *, gsm_signal *));
- extern void gsm_implode GSM_P((gsm, gsm_signal *, gsm_byte *));
-
-+#ifdef __cplusplus
-+}
-+#endif
-+
- #undef GSM_P
-
- #endif /* GSM_H */
diff --git a/recipes-isdn/libgsm/libgsm-1.0.13/04_includes.patch b/recipes-isdn/libgsm/libgsm-1.0.13/04_includes.patch
deleted file mode 100644
index 2769b40..0000000
--- a/recipes-isdn/libgsm/libgsm-1.0.13/04_includes.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-diff -urNad libgsm-1.0.10~/inc/toast.h libgsm-1.0.10/inc/toast.h
---- libgsm-1.0.10~/inc/toast.h 2007-11-01 15:37:52.000000000 +0100
-+++ libgsm-1.0.10/inc/toast.h 2007-11-01 15:52:33.000000000 +0100
-@@ -16,11 +16,12 @@
-
- #include <stdio.h>
- #include <ctype.h>
-+#include <pthread.h>
- #include <signal.h>
-
- #include <errno.h>
--#ifndef HAS_ERRNO_DECL
-- extern int errno;
-+#ifndef errno
-+ extern int errno;
- #endif
-
- #ifdef HAS_LIMITS_H
-@@ -37,6 +38,10 @@
- # endif
- #endif
-
-+#ifdef HAS_STDIO_H
-+# include <stdio.h>
-+#endif
-+
- #include "gsm.h"
-
- #ifndef S_ISREG
-diff -urNad libgsm-1.0.10~/src/code.c libgsm-1.0.10/src/code.c
---- libgsm-1.0.10~/src/code.c 2007-11-01 15:37:52.000000000 +0100
-+++ libgsm-1.0.10/src/code.c 2007-11-01 15:52:33.000000000 +0100
-@@ -9,8 +9,8 @@
- #include "config.h"
-
-
--#ifdef HAS_STDLIB_H
--#include <stdlib.h>
-+#ifdef HAS_STRING_H
-+#include <string.h>
- #else
- # include "proto.h"
- extern char * memcpy P((char *, char *, int));
diff --git a/recipes-isdn/libgsm/libgsm_1.0.13.bb b/recipes-isdn/libgsm/libgsm_1.0.14.bb
index fb16037..8d90ffc 100644
--- a/recipes-isdn/libgsm/libgsm_1.0.13.bb
+++ b/recipes-isdn/libgsm/libgsm_1.0.14.bb
@@ -1,22 +1,22 @@
DESCRIPTION = "GSM Audio Library"
SECTION = "libs"
PRIORITY = "optional"
-LICENSE = "libgsm"
+LICENSE = "ISC"
LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=fc1372895b173aaf543a122db37e04f5"
SRC_URI = "\
http://www.quut.com/gsm/gsm-${PV}.tar.gz \
- file://01_makefile.patch \
- file://02_cplusplus.patch \
- file://03_config.patch \
- file://04_includes.patch \
- file://05_compiler_warnings.patch \
+ file://0001-Configure-Makefile.patch \
+ file://0002-Add-defines-to-c.patch \
+ file://0003-Use-gsm_config.-header-instead-of-config.h.patch \
+ file://0004-Add-includes.patch \
+ file://0005-Change-compiler-warnings.patch \
"
-S = "${WORKDIR}/gsm-1.0-pl13/"
+SRC_URI[md5sum] = "4cbb4e7b73842de3d12d30b0d74200d4"
+SRC_URI[sha256sum] = "5814a16a30b3c026871b3739812dc4a2a84299331182c987da1c212c93e9352c"
-SRC_URI[md5sum] = "c1ba392ce61dc4aff1c29ea4e92f6df4"
-SRC_URI[sha256sum] = "52c518244d428c2e56c543b98c9135f4a76ff780c32455580b793f60a0a092ad"
+S = "${WORKDIR}/gsm-1.0-pl14/"
CFLAGS += "-c -g -fPIC -Wall -D_GNU_SOURCE -D_REENTRANT -DNeedFunctionPrototypes=1 -DWAV49 -I./inc"