aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-osmocom
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <holger@moiji-mobile.com>2014-10-02 18:51:14 +0200
committerHolger Hans Peter Freyther <holger@moiji-mobile.com>2014-10-07 17:04:21 +0200
commitb28405e6a0706fe560bb29efc2691df9e22d092b (patch)
treebaa2df74f9aa61aeaff6b8e852c2b27dcf0c3060 /recipes-osmocom
parent5e186d3d1f467eb4ea95bc27475fdf20a8db5ee9 (diff)
libosmo-abis: Revert parts of the multi-TRX support in libosmo-abis
The line doesn't have the signalling type set yet. It will be set _after_ the rsl connection is considered up. This is addressing RSL Connection failures like: <0001> oml.c:1026 Rx IPA RSL CONNECT IP=1.2.3.4 PORT=3003 STREAM=0x00 <000f> input/ipaccess.c:921 cannot create RSL BTS link: trx_nr (0) does not refer to a signalling link <0001> oml.c:1030 Error in abis_open(RSL): -22 <0001> oml.c:341 Sending FOM NACK with cause Message cannot be performed.
Diffstat (limited to 'recipes-osmocom')
-rw-r--r--recipes-osmocom/libosmo-abis/files/fix-rsl-connect.patch21
-rw-r--r--recipes-osmocom/libosmo-abis/libosmo-abis_git.bb5
2 files changed, 24 insertions, 2 deletions
diff --git a/recipes-osmocom/libosmo-abis/files/fix-rsl-connect.patch b/recipes-osmocom/libosmo-abis/files/fix-rsl-connect.patch
new file mode 100644
index 0000000..63c5052
--- /dev/null
+++ b/recipes-osmocom/libosmo-abis/files/fix-rsl-connect.patch
@@ -0,0 +1,21 @@
+The line is not initiliazed to E1INP_TS_TYPE_SIGN by default
+
+diff --git a/src/input/ipaccess.c b/src/input/ipaccess.c
+index 145e471..49424e7 100644
+--- a/src/input/ipaccess.c
++++ b/src/input/ipaccess.c
+@@ -915,12 +915,14 @@ int e1inp_ipa_bts_rsl_connect_n(struct e1inp_line *line,
+ "trx_nr (%d) out of range\n", trx_nr);
+ return -EINVAL;
+ }
++/*
+ if (line->ts[E1INP_SIGN_RSL+trx_nr-1].type != E1INP_TS_TYPE_SIGN) {
+ LOGP(DLINP, LOGL_ERROR, "cannot create RSL BTS link: "
+ "trx_nr (%d) does not refer to a signalling link\n",
+ trx_nr);
+ return -EINVAL;
+ }
++*/
+
+ rsl_link = ipa_client_conn_create(tall_ipa_ctx,
+ &line->ts[E1INP_SIGN_RSL+trx_nr-1],
diff --git a/recipes-osmocom/libosmo-abis/libosmo-abis_git.bb b/recipes-osmocom/libosmo-abis/libosmo-abis_git.bb
index 52c7c98..fd8e8fd 100644
--- a/recipes-osmocom/libosmo-abis/libosmo-abis_git.bb
+++ b/recipes-osmocom/libosmo-abis/libosmo-abis_git.bb
@@ -2,6 +2,7 @@ require ${PN}.inc
S = "${WORKDIR}/git"
SRCREV = "d9d1b5c19f40515cb7c660acda7265bbddbb73d6"
-SRC_URI = "git://git.osmocom.org/libosmo-abis.git;protocol=git"
+SRC_URI = "git://git.osmocom.org/libosmo-abis.git;protocol=git \
+ file://fix-rsl-connect.patch "
PV = "0.3.0+gitr${SRCPV}"
-PR = "${INC_PR}.0"
+PR = "${INC_PR}.1"