aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-osmocom/openggsn
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <holger@moiji-mobile.com>2014-03-21 18:45:56 +0100
committerHolger Hans Peter Freyther <holger@moiji-mobile.com>2014-03-21 19:12:46 +0100
commitcedace00ed848433a728cc449e1f58207fa9c5ba (patch)
treeadd8988cded4f1aebe4ed20ebcfc93bf5f2e044e /recipes-osmocom/openggsn
parentd496a8d59b0534fddbf2807e3474d9e7bea1308b (diff)
openggsn: Update and install systemd service file
This might require to rebuild the freshly built openggsn to fix the libgtp0 depedency. I had this issue on Dora without a PRServer. I am not sure it applies to edison or other configs. Bump the PR of OpenBSC to force a rebuild of the SGSN. Fixes: SYS#176
Diffstat (limited to 'recipes-osmocom/openggsn')
-rw-r--r--recipes-osmocom/openggsn/openggsn_git.bb8
1 files changed, 6 insertions, 2 deletions
diff --git a/recipes-osmocom/openggsn/openggsn_git.bb b/recipes-osmocom/openggsn/openggsn_git.bb
index ebcfee6..4da39ef 100644
--- a/recipes-osmocom/openggsn/openggsn_git.bb
+++ b/recipes-osmocom/openggsn/openggsn_git.bb
@@ -4,8 +4,8 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=8ca43cbc842c2336e835926c2166c28b"
PV = "0.91+gitr${SRCPV}"
PR = "r12"
-SRCREV = "95848bafcef145d776d70a73f7bdc3fe37e85724"
-SRC_URI = "git://ggsn.git.sourceforge.net/gitroot/ggsn/ggsn \
+SRCREV = "4afb44a25ebe9d33886531c0a1c549d70da198bd"
+SRC_URI = "git://git.osmocom.org/openggsn \
file://openggsn.init \
file://libgtp-queue_depth_32.patch \
"
@@ -18,7 +18,10 @@ inherit autotools update-rc.d
do_install_append() {
install -d ${D}${sysconfdir}/init.d
+ install -d ${D}${systemd_unitdir}/system
+
install -m 0776 ${WORKDIR}/openggsn.init ${D}${sysconfdir}/init.d/openggsn
+ install -m 0644 ${S}/contrib/openggsn.service ${D}${systemd_unitdir}/system/
}
INITSCRIPT_PACKAGES = "openggsn"
@@ -32,3 +35,4 @@ FILES_libgtp-dev = "${includedir} ${libdir}/lib*${SOLIBSDEV} ${libdir}/*.la"
FILES_libgtp-staticdev = "${libdir}/*.a"
FILES_openggsn-sgsnemu = "${bindir}/sgsnemu"
+FILES_${PN} += "${systemd_unitdir}/system/*"