aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-isdn
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <zecke@selfish.org>2012-01-16 16:08:45 +0800
committerHolger Hans Peter Freyther <zecke@selfish.org>2012-01-16 16:38:41 +0800
commite77df798a7b091d7157a57e19a0ed3469f22e022 (patch)
tree3d9e6414982ab5aeda368a0119e6610164608fdc /recipes-isdn
parent956671540540dcc1993782aa52f5a75017c95a00 (diff)
asterisk: Band aid for a crash on RTP RTCP message
This might be a general TLS issue with Asterisk on ARM. I have not looked into why this is happening. Create a band-aid. Crash: (gdb) bt it crashed when formating/printing the &addr in the rtcp recv method ... RTCP: Packet generated from Ekiga 3.2.7 (Debian Unstable). Cause: Not very clear, maybe something with TLS handling of asterisk
Diffstat (limited to 'recipes-isdn')
-rw-r--r--recipes-isdn/asterisk/asterisk_1.8.8.1.bb7
-rw-r--r--recipes-isdn/asterisk/files/stop-crash.patch13
2 files changed, 17 insertions, 3 deletions
diff --git a/recipes-isdn/asterisk/asterisk_1.8.8.1.bb b/recipes-isdn/asterisk/asterisk_1.8.8.1.bb
index 869de25..f31ae33 100644
--- a/recipes-isdn/asterisk/asterisk_1.8.8.1.bb
+++ b/recipes-isdn/asterisk/asterisk_1.8.8.1.bb
@@ -1,5 +1,5 @@
# Copyright (C) 2007-2008, Stelios Koroneos - Digital OPSiS, All Rights Reserved
-# Copyright (C) 2011, sysmocom - systems for mobile communications GmbH
+# Copyright (C) 2011-2012, sysmocom - systems for mobile communications GmbH
# Released under the MIT license (see packages/COPYING)
DESCRITOPN = "asterisk PBX"
DEPENDS = "openssl ncurses"
@@ -7,11 +7,12 @@ HOMEPAGE = "http://www.asterisk.org"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=3c6764ffcbe996d1d8f919b393ccdd67"
-PR = "r3"
+PR = "r4"
SRC_URI = "http://downloads.asterisk.org/pub/telephony/asterisk/releases/asterisk-${PV}.tar.gz \
file://modules.conf \
- file://asterisk.init "
+ file://asterisk.init \
+ file://stop-crash.patch "
SRC_URI[md5sum] = "783b2da2036745edeea8885c62bbc8bf"
SRC_URI[sha256sum] = "ed98204f6261e1362c673e595823c668ae39b9833daec9127a4936cf9f4890e1"
diff --git a/recipes-isdn/asterisk/files/stop-crash.patch b/recipes-isdn/asterisk/files/stop-crash.patch
new file mode 100644
index 0000000..3fe0d5e
--- /dev/null
+++ b/recipes-isdn/asterisk/files/stop-crash.patch
@@ -0,0 +1,13 @@
+Index: asterisk-1.8.8.1/res/res_rtp_asterisk.c
+===================================================================
+--- asterisk-1.8.8.1.orig/res/res_rtp_asterisk.c 2011-09-20 08:56:20.000000000 +0800
++++ asterisk-1.8.8.1/res/res_rtp_asterisk.c 2012-01-16 02:45:57.227713136 +0800
+@@ -1902,7 +1902,7 @@
+ "IAJitter: %u\r\n"
+ "LastSR: %lu.%010lu\r\n"
+ "DLSR: %4.4f(sec)\r\n",
+- ast_sockaddr_stringify(&addr),
++ "NA" /*ast_sockaddr_stringify(&addr)*/,
+ pt, (pt == 200) ? "Sender Report" : (pt == 201) ? "Receiver Report" : (pt == 192) ? "H.261 FUR" : "Unknown",
+ rc,
+ rtcpheader[i + 1],