aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPau Espin Pedrol <pespin@sysmocom.de>2017-09-25 19:19:30 +0200
committerPau Espin Pedrol <pespin@sysmocom.de>2017-09-26 14:21:32 +0200
commit74aa19e1be6dcb34d1b3996050dbecba514928a7 (patch)
tree59bb7a6132710a1f23857c306227bf3230ab6807
parente246a54db29bf5df3509b771271a1ca787339ff6 (diff)
WIP
-rw-r--r--recipes-osmocom/libasn1c/libasn1c_git.bb16
-rw-r--r--recipes-osmocom/osmo-bsc/osmo-bsc.inc10
-rw-r--r--recipes-osmocom/osmo-bsc/osmo-bsc_git.bb28
-rw-r--r--recipes-osmocom/osmo-hlr/osmo-hlr.inc12
-rw-r--r--recipes-osmocom/osmo-hlr/osmo-hlr_git.bb17
-rw-r--r--recipes-osmocom/osmo-iuh/osmo-iuh.inc10
-rw-r--r--recipes-osmocom/osmo-iuh/osmo-iuh_git.bb17
-rw-r--r--recipes-osmocom/osmo-mgw/osmo-mgw.inc10
-rw-r--r--recipes-osmocom/osmo-mgw/osmo-mgw_git.bb19
-rw-r--r--recipes-osmocom/osmo-msc/osmo-msc.inc14
-rw-r--r--recipes-osmocom/osmo-msc/osmo-msc_git.bb17
-rw-r--r--recipes-osmocom/osmo-sgsn/osmo-sgsn.inc11
-rw-r--r--recipes-osmocom/osmo-sgsn/osmo-sgsn_git.bb36
13 files changed, 217 insertions, 0 deletions
diff --git a/recipes-osmocom/libasn1c/libasn1c_git.bb b/recipes-osmocom/libasn1c/libasn1c_git.bb
new file mode 100644
index 0000000..ed2de93
--- /dev/null
+++ b/recipes-osmocom/libasn1c/libasn1c_git.bb
@@ -0,0 +1,16 @@
+SUMMARY = "Rruntime library of Lev Walkin's asn1c split out as separate library"
+HOMEPAGE = "https://osmocom.org/"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://COPYING;md5=25192323023bb0db6998ac6fcd5aa6a1"
+
+S = "${WORKDIR}/git"
+SRCREV = "aaae8c76496a97050264e4c49e539b0420496737"
+SRC_URI = "git://git.osmocom.org/libasn1c.git;protocol=git"
+
+DEPENDS += "libtalloc"
+
+inherit autotools pkgconfig
+
+INC_PR="r0.${META_TELEPHONY_OSMO_INC}"
+PV = "0.9.28+gitr${SRCPV}"
+PR = "r0"
diff --git a/recipes-osmocom/osmo-bsc/osmo-bsc.inc b/recipes-osmocom/osmo-bsc/osmo-bsc.inc
new file mode 100644
index 0000000..d707629
--- /dev/null
+++ b/recipes-osmocom/osmo-bsc/osmo-bsc.inc
@@ -0,0 +1,10 @@
+DESCRITOPN = "Osmocom BSC implementation"
+HOMEPAGE = "https://osmocom.org/"
+LICENSE = "AGPLv3"
+LIC_FILES_CHKSUM = "file://COPYING;md5=73f1eb20517c55bf9493b7dd6e480788"
+
+INC_PR="r0.${META_TELEPHONY_OSMO_INC}"
+
+inherit autotools pkgconfig systemd
+
+DEPENDS = "libdbi sqlite3 libosmocore libosmo-abis libosmo-sccp libosmo-netif osmo-mgw"
diff --git a/recipes-osmocom/osmo-bsc/osmo-bsc_git.bb b/recipes-osmocom/osmo-bsc/osmo-bsc_git.bb
new file mode 100644
index 0000000..454db71
--- /dev/null
+++ b/recipes-osmocom/osmo-bsc/osmo-bsc_git.bb
@@ -0,0 +1,28 @@
+require ${PN}.inc
+
+S = "${WORKDIR}/git"
+SRCREV = "a9594b5058dc5a62ea813e7b577951e53e848ffc"
+SRC_URI = "git://git.osmocom.org/osmo-bsc.git;protocol=git"
+PV = "1.0.1+gitr${SRCPV}"
+PR = "${INC_PR}.0"
+
+do_install_append() {
+ install -d ${D}${systemd_system_unitdir}/
+ install -d ${D}${sysconfdir}/osmocom/
+
+ install -m 0644 ${S}/doc/examples/osmo-bsc/osmo-bsc.cfg ${D}${sysconfdir}/osmocom/
+ install -m 0644 ${S}/doc/examples/osmo-bsc_nat/osmo-bsc_nat.cfg ${D}${sysconfdir}/osmocom/
+
+ install -m 0644 ${S}/contrib/systemd/osmo-bsc.service ${D}${systemd_system_unitdir}/
+}
+
+PACKAGES =+ "osmo-bsc-nat-doc osmo-bsc-nat"
+SYSTEMD_PACKAGES = "osmo-bsc"
+SYSTEMD_SERVICE_osmo-bsc = "osmo-bsc.service"
+
+FILES_osmo-bsc-nat = " \
+ ${bindir}/osmo-bsc_nat \
+ ${sysconfdir}/osmocom/osmo-bsc_nat.cfg \
+ "
+
+FILES_osmo-bsc-nat-doc = " ${docdir}/osmo-bsc/examples/osmo-bsc_nat "
diff --git a/recipes-osmocom/osmo-hlr/osmo-hlr.inc b/recipes-osmocom/osmo-hlr/osmo-hlr.inc
new file mode 100644
index 0000000..ba4ebd7
--- /dev/null
+++ b/recipes-osmocom/osmo-hlr/osmo-hlr.inc
@@ -0,0 +1,12 @@
+DESCRITOPN = "Osmocom HLR implementation"
+DEPENDS = "libdbi libtalloc libosmocore libosmo-abis sqlite3"
+HOMEPAGE = "https://osmocom.org/"
+LICENSE = "AGPLv3"
+
+INC_PR="r0.${META_TELEPHONY_OSMO_INC}"
+
+LIC_FILES_CHKSUM = "file://COPYING;md5=73f1eb20517c55bf9493b7dd6e480788"
+
+inherit autotools pkgconfig systemd
+
+RDEPENDS_${PN} = "libdbd-sqlite3"
diff --git a/recipes-osmocom/osmo-hlr/osmo-hlr_git.bb b/recipes-osmocom/osmo-hlr/osmo-hlr_git.bb
new file mode 100644
index 0000000..a30fe0f
--- /dev/null
+++ b/recipes-osmocom/osmo-hlr/osmo-hlr_git.bb
@@ -0,0 +1,17 @@
+require ${PN}.inc
+
+S = "${WORKDIR}/git"
+SRCREV = "05c8b465ab2fe13edb67c95210a9b475f91ebeb3"
+SRC_URI = "git://git.osmocom.org/osmo-hlr.git;protocol=git"
+PV = "0.0.1+gitr${SRCPV}"
+PR = "${INC_PR}.0"
+
+do_install_append() {
+ install -d ${D}${systemd_system_unitdir}/
+ install -d ${D}${sysconfdir}/osmocom/
+
+ install -m 0644 ${S}/doc/examples/osmo-hlr.cfg ${D}${sysconfdir}/osmocom/
+ install -m 0644 ${S}/contrib/systemd/osmo-hlr.service ${D}${systemd_system_unitdir}/
+}
+
+SYSTEMD_SERVICE_${PN} = "${PN}.service"
diff --git a/recipes-osmocom/osmo-iuh/osmo-iuh.inc b/recipes-osmocom/osmo-iuh/osmo-iuh.inc
new file mode 100644
index 0000000..3e56b16
--- /dev/null
+++ b/recipes-osmocom/osmo-iuh/osmo-iuh.inc
@@ -0,0 +1,10 @@
+DESCRITOPN = "Osmocom Iuh and HNB-GW implementation"
+DEPENDS = "libosmocore libosmo-netif libosmo-sccp libasn1c"
+HOMEPAGE = "https://osmocom.org/"
+LICENSE = "AGPLv3"
+
+INC_PR="r0.${META_TELEPHONY_OSMO_INC}"
+
+LIC_FILES_CHKSUM = "file://COPYING;md5=73f1eb20517c55bf9493b7dd6e480788"
+
+inherit autotools pkgconfig systemd
diff --git a/recipes-osmocom/osmo-iuh/osmo-iuh_git.bb b/recipes-osmocom/osmo-iuh/osmo-iuh_git.bb
new file mode 100644
index 0000000..4e53446
--- /dev/null
+++ b/recipes-osmocom/osmo-iuh/osmo-iuh_git.bb
@@ -0,0 +1,17 @@
+require ${PN}.inc
+
+S = "${WORKDIR}/git"
+SRCREV = "5a3df8fa9ffc4400367250a0f9ff0e20dc4b5d3b"
+SRC_URI = "git://git.osmocom.org/osmo-iuh.git;protocol=git"
+PV = "0.1.0+gitr${SRCPV}"
+PR = "${INC_PR}.0"
+
+do_install_append() {
+ install -d ${D}${systemd_system_unitdir}/
+ install -d ${D}${sysconfdir}/osmocom/
+
+ install -m 0644 ${S}/doc/examples/osmo-hnbgw.cfg ${D}${sysconfdir}/osmocom/
+ install -m 0644 ${S}/contrib/systemd/osmo-hnbgw.service ${D}${systemd_system_unitdir}/
+}
+
+SYSTEMD_SERVICE_osmo-iuh = "osmo-hnbgw.service"
diff --git a/recipes-osmocom/osmo-mgw/osmo-mgw.inc b/recipes-osmocom/osmo-mgw/osmo-mgw.inc
new file mode 100644
index 0000000..cd53b79
--- /dev/null
+++ b/recipes-osmocom/osmo-mgw/osmo-mgw.inc
@@ -0,0 +1,10 @@
+DESCRITOPN = "Osmocom Media Gateway (MGCP) implementation"
+DEPENDS = "libosmocore libosmo-netif bcg729 libgsm"
+HOMEPAGE = "https://osmocom.org/"
+LICENSE = "AGPLv3"
+
+INC_PR="r0.${META_TELEPHONY_OSMO_INC}"
+
+LIC_FILES_CHKSUM = "file://COPYING;md5=73f1eb20517c55bf9493b7dd6e480788"
+
+inherit autotools pkgconfig systemd
diff --git a/recipes-osmocom/osmo-mgw/osmo-mgw_git.bb b/recipes-osmocom/osmo-mgw/osmo-mgw_git.bb
new file mode 100644
index 0000000..aeaaf53
--- /dev/null
+++ b/recipes-osmocom/osmo-mgw/osmo-mgw_git.bb
@@ -0,0 +1,19 @@
+require ${PN}.inc
+
+S = "${WORKDIR}/git"
+SRCREV = "1c8d67d7f5f6f8788d92df65a0b68e0ec19a34dc"
+SRC_URI = "git://git.osmocom.org/osmo-mgw.git;protocol=git"
+PV = "1.0.2+gitr${SRCPV}"
+PR = "${INC_PR}.0"
+
+EXTRA_OECONF += "--enable-mgcp-transcoding --with-g729"
+
+do_install_append() {
+ install -d ${D}${systemd_system_unitdir}/
+ install -d ${D}${sysconfdir}/osmocom/
+
+ install -m 0644 ${S}/doc/examples/osmo-bsc_mgcp/mgcp.cfg ${D}${sysconfdir}/osmocom/osmo-bsc-mgcp.cfg
+ install -m 0644 ${S}/contrib/systemd/osmo-bsc-mgcp.service ${D}${systemd_system_unitdir}/
+}
+
+SYSTEMD_SERVICE_osmo-mgw = "osmo-bsc-mgcp.service"
diff --git a/recipes-osmocom/osmo-msc/osmo-msc.inc b/recipes-osmocom/osmo-msc/osmo-msc.inc
new file mode 100644
index 0000000..872d6dc
--- /dev/null
+++ b/recipes-osmocom/osmo-msc/osmo-msc.inc
@@ -0,0 +1,14 @@
+DESCRITOPN = "Osmocom MSC implementation"
+DEPENDS = "libdbi libasn1c osmo-iuh libosmocore libosmo-abis libosmo-sccp libosmo-netif libsmpp34 osmo-mgw"
+HOMEPAGE = "https://osmocom.org/"
+LICENSE = "AGPLv3"
+
+INC_PR="r0.${META_TELEPHONY_OSMO_INC}"
+
+LIC_FILES_CHKSUM = "file://COPYING;md5=73f1eb20517c55bf9493b7dd6e480788"
+
+inherit autotools pkgconfig systemd
+
+EXTRA_OECONF += "--enable-smpp --enable-iu"
+
+RDEPENDS_${PN} = "libdbd-sqlite3"
diff --git a/recipes-osmocom/osmo-msc/osmo-msc_git.bb b/recipes-osmocom/osmo-msc/osmo-msc_git.bb
new file mode 100644
index 0000000..9854499
--- /dev/null
+++ b/recipes-osmocom/osmo-msc/osmo-msc_git.bb
@@ -0,0 +1,17 @@
+require ${PN}.inc
+
+S = "${WORKDIR}/git"
+SRCREV = "4e7ece0bd969389132d7babf8de4f57cf7d0126f"
+SRC_URI = "git://git.osmocom.org/osmo-msc.git;protocol=git"
+PV = "1.0.1+gitr${SRCPV}"
+PR = "${INC_PR}.0"
+
+do_install_append() {
+ install -d ${D}${systemd_system_unitdir}/
+ install -d ${D}${sysconfdir}/osmocom/
+
+ install -m 0644 ${S}/doc/examples/osmo-msc/osmo-msc.cfg ${D}${sysconfdir}/osmocom/
+ install -m 0644 ${S}/contrib/systemd/osmo-msc.service ${D}${systemd_system_unitdir}/
+}
+
+SYSTEMD_SERVICE_${PN} = "${PN}.service"
diff --git a/recipes-osmocom/osmo-sgsn/osmo-sgsn.inc b/recipes-osmocom/osmo-sgsn/osmo-sgsn.inc
new file mode 100644
index 0000000..8395866
--- /dev/null
+++ b/recipes-osmocom/osmo-sgsn/osmo-sgsn.inc
@@ -0,0 +1,11 @@
+DESCRITOPN = "Osmocom SGSN implementation"
+HOMEPAGE = "https://osmocom.org/"
+LICENSE = "AGPLv3"
+LIC_FILES_CHKSUM = "file://COPYING;md5=73f1eb20517c55bf9493b7dd6e480788"
+
+INC_PR="r0.${META_TELEPHONY_OSMO_INC}"
+
+inherit autotools pkgconfig systemd
+
+DEPENDS = "c-ares libpcap libasn1c libosmocore libosmo-netif osmo-iuh osmo-ggsn"
+EXTRA_OECONF += "--enable-iu"
diff --git a/recipes-osmocom/osmo-sgsn/osmo-sgsn_git.bb b/recipes-osmocom/osmo-sgsn/osmo-sgsn_git.bb
new file mode 100644
index 0000000..dce753e
--- /dev/null
+++ b/recipes-osmocom/osmo-sgsn/osmo-sgsn_git.bb
@@ -0,0 +1,36 @@
+require ${PN}.inc
+
+S = "${WORKDIR}/git"
+SRCREV = "341d446b4db87b48812afe8d2149ebc840e8a357"
+SRC_URI = "git://git.osmocom.org/osmo-sgsn.git;protocol=git"
+PV = "0.1.0+gitr${SRCPV}"
+PR = "${INC_PR}.0"
+
+do_install_append() {
+ install -d ${D}${systemd_system_unitdir}/
+ install -d ${D}${sysconfdir}/osmocom/
+
+ install -m 0644 ${S}/doc/examples/osmo-sgsn/osmo-sgsn.cfg ${D}${sysconfdir}/osmocom/
+ install -m 0644 ${S}/doc/examples/osmo-gbproxy/osmo-gbproxy.cfg ${D}${sysconfdir}/osmocom/
+
+ install -m 0644 ${S}/contrib/systemd/osmo-sgsn.service ${D}${systemd_system_unitdir}/
+ install -m 0644 ${S}/contrib/systemd/osmo-gbproxy.service ${D}${systemd_system_unitdir}/
+}
+
+PACKAGES =+ "osmo-gbproxy-doc osmo-gtphub-doc osmo-gbproxy osmo-gtphub"
+SYSTEMD_PACKAGES = "osmo-sgsn osmo-gbproxy"
+SYSTEMD_SERVICE_osmo-sgsn = "osmo-sgsn.service"
+SYSTEMD_SERVICE_osmo-gbproxy = "osmo-gbproxy.service"
+
+FILES_osmo-gbproxy = " \
+ ${bindir}/osmo-gbproxy \
+ ${sysconfdir}/osmocom/osmo-gbproxy.cfg \
+ "
+
+FILES_osmo-gtphub = " \
+ ${bindir}/osmo-gtphub \
+ ${sysconfdir}/osmocom/osmo-gtphub.cfg \
+ "
+
+FILES_osmo-gbproxy-doc = " ${docdir}/osmo-sgsn/examples/osmo-gbproxy "
+FILES_osmo-gtphub-doc = " ${docdir}/osmo-sgsn/examples/osmo-gtphub "