aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPau Espin Pedrol <pespin@sysmocom.de>2017-09-26 14:30:33 +0200
committerPau Espin Pedrol <pespin@sysmocom.de>2017-09-29 14:20:07 +0200
commit8eb42575096f6227e83228e3d8fbf591f9cedb22 (patch)
tree1d1cd42dc92aead7e0e25576d53c35b188d5505f
parent8554d8a42c0e2ed7f0e39ba76cd3aee78dde6f30 (diff)
osmo-msc: Introduce recipe
-rw-r--r--recipes-osmocom/osmo-msc/osmo-msc.inc24
-rw-r--r--recipes-osmocom/osmo-msc/osmo-msc_git.bb7
2 files changed, 31 insertions, 0 deletions
diff --git a/recipes-osmocom/osmo-msc/osmo-msc.inc b/recipes-osmocom/osmo-msc/osmo-msc.inc
new file mode 100644
index 0000000..b4decf9
--- /dev/null
+++ b/recipes-osmocom/osmo-msc/osmo-msc.inc
@@ -0,0 +1,24 @@
+DESCRIPTION = "Osmocom MSC implementation"
+HOMEPAGE = "https://osmocom.org/projects/osmomsc"
+LICENSE = "AGPLv3"
+LIC_FILES_CHKSUM = "file://COPYING;md5=73f1eb20517c55bf9493b7dd6e480788"
+
+DEPENDS = "libdbi libasn1c osmo-iuh libosmocore libosmo-abis libosmo-sccp libosmo-netif libsmpp34 osmo-mgw"
+
+INC_PR="r0.${META_TELEPHONY_OSMO_INC}"
+
+inherit autotools pkgconfig systemd
+
+EXTRA_OECONF += "--enable-smpp --enable-iu"
+
+RDEPENDS_${PN} = "libdbd-sqlite3"
+
+do_install_append() {
+ install -d ${D}${systemd_system_unitdir}/
+ install -d ${D}${sysconfdir}/osmocom/
+
+ install -m 0644 ${S}/doc/examples/osmo-msc/osmo-msc.cfg ${D}${sysconfdir}/osmocom/
+ install -m 0644 ${S}/contrib/systemd/osmo-msc.service ${D}${systemd_system_unitdir}/
+}
+
+SYSTEMD_SERVICE_${PN} = "${PN}.service"
diff --git a/recipes-osmocom/osmo-msc/osmo-msc_git.bb b/recipes-osmocom/osmo-msc/osmo-msc_git.bb
new file mode 100644
index 0000000..7d55237
--- /dev/null
+++ b/recipes-osmocom/osmo-msc/osmo-msc_git.bb
@@ -0,0 +1,7 @@
+require ${PN}.inc
+
+S = "${WORKDIR}/git"
+SRCREV = "4e7ece0bd969389132d7babf8de4f57cf7d0126f"
+SRC_URI = "git://git.osmocom.org/osmo-msc.git;protocol=git"
+PV = "1.0.1+gitr${SRCPV}"
+PR = "${INC_PR}.0"