aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPau Espin Pedrol <pespin@sysmocom.de>2017-09-25 17:46:29 +0200
committerPau Espin Pedrol <pespin@sysmocom.de>2017-09-29 14:04:26 +0200
commit73eade5890d3d11752679e1dffb91bd910464c3e (patch)
tree460451e9eff9e8b9400299dc6670206d93d45729
parentd7e9e0e836f0fd45e55243bad19449a396c3cb04 (diff)
Drop openggsn and introduce osmo-ggsn
Take the opportunity to enable systemd service instead of sysvint like other osmocom services already do. Change-Id: Ie6018ef78ff18f2e6809fee957c9d645e35c7c9a
-rw-r--r--recipes-osmocom/openbsc/openbsc.inc5
-rw-r--r--recipes-osmocom/openggsn/openggsn_git.bb40
-rw-r--r--recipes-osmocom/osmo-ggsn/files/libgtp-queue_depth_32.patch (renamed from recipes-osmocom/openggsn/files/libgtp-queue_depth_32.patch)0
-rwxr-xr-xrecipes-osmocom/osmo-ggsn/files/osmo-ggsn.init (renamed from recipes-osmocom/openggsn/files/openggsn.init)6
-rw-r--r--recipes-osmocom/osmo-ggsn/osmo-ggsn_git.bb42
-rw-r--r--recipes-telephony/tasks/task-telephony-all.bb5
6 files changed, 49 insertions, 49 deletions
diff --git a/recipes-osmocom/openbsc/openbsc.inc b/recipes-osmocom/openbsc/openbsc.inc
index a965040..164b492 100644
--- a/recipes-osmocom/openbsc/openbsc.inc
+++ b/recipes-osmocom/openbsc/openbsc.inc
@@ -1,5 +1,5 @@
DESCRIPTION = "OpenBSC a Free Software GSM BaseStationController"
-DEPENDS = "libdbi libosmocore libosmo-sccp libosmo-abis libosmo-netif openggsn libsmpp34 bcg729 libgsm libpcap c-ares"
+DEPENDS = "libdbi libosmocore libosmo-sccp libosmo-abis libosmo-netif osmo-ggsn libsmpp34 bcg729 libgsm libpcap c-ares"
HOMEPAGE = "http://openbsc.osmocom.org/"
LICENSE = "AGPLv3+"
LIC_FILES_CHKSUM = "file://COPYING;md5=73f1eb20517c55bf9493b7dd6e480788"
@@ -11,7 +11,7 @@ SRC_URI = "file://osmo-nitb.init \
file://osmo-bsc.init \
file://osmo-sgsn.init"
-INC_PR = "r21.${META_TELEPHONY_OSMO_INC}"
+INC_PR = "r22.${META_TELEPHONY_OSMO_INC}"
EXTRA_OECONF += " --enable-nat --enable-osmo-bsc --enable-smpp --enable-mgcp-transcoding --with-g729"
@@ -97,4 +97,3 @@ FILES_osmo-gbproxy = " ${bindir}/osmo-gbproxy \
${systemd_unitdir}/system/osmo-gbproxy.service \
"
FILES_osmo-gbproxy-dbg = " ${bindir}/.debug/osmo-gbproxy "
-
diff --git a/recipes-osmocom/openggsn/openggsn_git.bb b/recipes-osmocom/openggsn/openggsn_git.bb
deleted file mode 100644
index 6190b22..0000000
--- a/recipes-osmocom/openggsn/openggsn_git.bb
+++ /dev/null
@@ -1,40 +0,0 @@
-DESCRITOPN = "OpenGGSN a Free Software GGSN"
-LICENSE = "GPLv2+"
-LIC_FILES_CHKSUM = "file://COPYING;md5=8ca43cbc842c2336e835926c2166c28b"
-PV = "0.94+gitr${SRCPV}"
-PR = "r0"
-
-SRCREV = "6045efb642918ac43056ca6a40cda2fe2e6db08d"
-SRC_URI = "git://git.osmocom.org/openggsn \
- file://openggsn.init \
- file://libgtp-queue_depth_32.patch \
- "
-S = "${WORKDIR}/git"
-
-DEPENDS = "libosmocore"
-
-PACKAGES =+ " libgtp libgtp-dev libgtp-staticdev openggsn-sgsnemu"
-RDEPENDS_${PN} += "kernel-module-tun"
-
-inherit autotools update-rc.d pkgconfig
-
-do_install_append() {
- install -d ${D}${sysconfdir}/init.d
- install -d ${D}${systemd_unitdir}/system
-
- install -m 0776 ${WORKDIR}/openggsn.init ${D}${sysconfdir}/init.d/openggsn
- install -m 0644 ${S}/contrib/openggsn.service ${D}${systemd_unitdir}/system/
-}
-
-INITSCRIPT_PACKAGES = "openggsn"
-
-INITSCRIPT_NAME_openggsn = "openggsn"
-INITSCRIPT_PARAMS_openggsn = "defaults 29 29"
-RDEPENDS_${PN} += "iptables kernel-module-ipt-masquerade"
-
-FILES_libgtp = "${libdir}/*${SOLIBS}"
-FILES_libgtp-dev = "${includedir} ${libdir}/lib*${SOLIBSDEV} ${libdir}/*.la"
-FILES_libgtp-staticdev = "${libdir}/*.a"
-
-FILES_openggsn-sgsnemu = "${bindir}/sgsnemu"
-FILES_${PN} += "${systemd_unitdir}/system/*"
diff --git a/recipes-osmocom/openggsn/files/libgtp-queue_depth_32.patch b/recipes-osmocom/osmo-ggsn/files/libgtp-queue_depth_32.patch
index 52bc37b..52bc37b 100644
--- a/recipes-osmocom/openggsn/files/libgtp-queue_depth_32.patch
+++ b/recipes-osmocom/osmo-ggsn/files/libgtp-queue_depth_32.patch
diff --git a/recipes-osmocom/openggsn/files/openggsn.init b/recipes-osmocom/osmo-ggsn/files/osmo-ggsn.init
index 695a6cc..157d6dd 100755
--- a/recipes-osmocom/openggsn/files/openggsn.init
+++ b/recipes-osmocom/osmo-ggsn/files/osmo-ggsn.init
@@ -1,6 +1,6 @@
#!/bin/sh
### BEGIN INIT INFO
-# Provides: openggsn
+# Provides: osmo-ggsn
# Required-Start: $network $local_fs
# Required-Stop:
# Default-Start: 2 3 4 5
@@ -15,8 +15,8 @@
# PATH should only include /usr/* if it runs after the mountnfs.sh script
PATH=/sbin:/usr/sbin:/bin:/usr/bin
-DESC="OpenGGSN Gateway GPRS Support Node"
-NAME=openggsn
+DESC="Osmocom GGSN implementation"
+NAME=osmo-ggsn
DAEMON=/usr/bin/ggsn
DAEMON_ARGS="" # Arguments to run the daemon with
PIDFILE=/var/run/$NAME.pid
diff --git a/recipes-osmocom/osmo-ggsn/osmo-ggsn_git.bb b/recipes-osmocom/osmo-ggsn/osmo-ggsn_git.bb
new file mode 100644
index 0000000..5a383b9
--- /dev/null
+++ b/recipes-osmocom/osmo-ggsn/osmo-ggsn_git.bb
@@ -0,0 +1,42 @@
+DESCRIPTION = "Osmocom GGSN implementation"
+HOMEPAGE = "https://osmocom.org/projects/openggsn"
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=8ca43cbc842c2336e835926c2166c28b"
+PV = "1.0.0+gitr${SRCPV}"
+PR = "r0"
+
+SRCREV = "b5624c3d4838cd774c3a6df4208b709890174a25"
+SRC_URI = "git://git.osmocom.org/osmo-ggsn \
+ file://osmo-ggsn.init \
+ file://libgtp-queue_depth_32.patch \
+ "
+S = "${WORKDIR}/git"
+
+DEPENDS = "libosmocore"
+
+PACKAGES =+ " libgtp libgtp-dev libgtp-staticdev osmo-sgsnemu"
+RDEPENDS_${PN} += "iptables kernel-module-ipt-masquerade kernel-module-tun"
+
+inherit autotools update-rc.d pkgconfig systemd
+
+do_install_append() {
+ install -d ${D}${sysconfdir}/init.d
+ install -d ${D}${systemd_system_unitdir}/
+ install -d ${D}/${sysconfdir}/osmocom/
+
+ install -m 0776 ${WORKDIR}/osmo-ggsn.init ${D}${sysconfdir}/init.d/osmo-ggsn
+ install -m 0644 ${S}/contrib/osmo-ggsn.service ${D}${systemd_system_unitdir}/
+ install -m 0644 ${S}/doc/examples/osmo-ggsn.cfg ${D}${sysconfdir}/osmocom/
+}
+
+SYSTEMD_SERVICE_osmo-ggsn = "osmo-ggsn.service"
+
+INITSCRIPT_PACKAGES = "osmo-ggsn"
+INITSCRIPT_NAME_osmo-ggsn = "osmo-ggsn"
+INITSCRIPT_PARAMS_osmo-ggsn = "defaults 29 29"
+
+FILES_libgtp = "${libdir}/*${SOLIBS}"
+FILES_libgtp-dev = "${includedir} ${libdir}/lib*${SOLIBSDEV} ${libdir}/*.la"
+FILES_libgtp-staticdev = "${libdir}/*.a"
+
+FILES_osmo-sgsnemu = "${bindir}/sgsnemu"
diff --git a/recipes-telephony/tasks/task-telephony-all.bb b/recipes-telephony/tasks/task-telephony-all.bb
index cc1ca0b..5efec10 100644
--- a/recipes-telephony/tasks/task-telephony-all.bb
+++ b/recipes-telephony/tasks/task-telephony-all.bb
@@ -3,7 +3,7 @@ LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420 \
file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
ALLOW_EMPTY_${PN} = "1"
-PR = "r4"
+PR = "r5"
DEPENDS = "\
libosmo-abis \
@@ -11,7 +11,7 @@ DEPENDS = "\
libosmocore \
openbsc \
packagegroup-osmocom \
- openggsn \
+ osmo-ggsn \
misdn-utils \
dahdi-linux \
dahdi-tools \
@@ -21,4 +21,3 @@ DEPENDS = "\
libdbi \
libdbi-drivers \
"
-