aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPau Espin Pedrol <pespin@sysmocom.de>2018-05-06 22:59:37 +0200
committerPau Espin Pedrol <pespin@sysmocom.de>2018-05-06 22:59:37 +0200
commit745ab774c942878a3ddd3a8a74b8b64561d59845 (patch)
treed2ff4cdd4e63a5d2bf1ee5e517d1eb4b5e7364b2
parentc5338d191e70d8799e8fcb602088b894598a528d (diff)
libosmo-sccp: Move version independent bits to .inc file
-rw-r--r--recipes-osmocom/libosmo-sccp/libosmo-sccp.inc22
-rw-r--r--recipes-osmocom/libosmo-sccp/libosmo-sccp_git.bb22
2 files changed, 22 insertions, 22 deletions
diff --git a/recipes-osmocom/libosmo-sccp/libosmo-sccp.inc b/recipes-osmocom/libosmo-sccp/libosmo-sccp.inc
index d269dae..c388c32 100644
--- a/recipes-osmocom/libosmo-sccp/libosmo-sccp.inc
+++ b/recipes-osmocom/libosmo-sccp/libosmo-sccp.inc
@@ -9,4 +9,26 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
inherit autotools pkgconfig systemd
+# we require the tests to link to the static libosmo-sigtran library to
+# access symbols not starting with osmo_*
+EXTRA_OECONF_remove = "--disable-static"
+
+PACKAGES =+ "osmo-stp"
+SYSTEMD_PACKAGES = "osmo-stp"
+SYSTEMD_SERVICE_osmo-stp = "osmo-stp.service"
+
+do_install_append() {
+ install -d ${D}${systemd_system_unitdir}/
+ install -d ${D}${sysconfdir}/osmocom/
+
+ install -m 0644 ${S}/doc/examples/osmo-stp.cfg ${D}${sysconfdir}/osmocom/
+ install -m 0644 ${S}/contrib/systemd/osmo-stp.service ${D}${systemd_system_unitdir}/
+}
+
+FILES_osmo-stp = " \
+ ${bindir}/osmo-stp \
+ ${sysconfdir}/osmocom/osmo-stp.cfg \
+ "
+CONFFILES_osmo-stp = "${sysconfdir}/osmocom/osmo-stp.cfg"
+
ALLOW_EMPTY_libosmo-sccp = "1"
diff --git a/recipes-osmocom/libosmo-sccp/libosmo-sccp_git.bb b/recipes-osmocom/libosmo-sccp/libosmo-sccp_git.bb
index b353acb..20cecb8 100644
--- a/recipes-osmocom/libosmo-sccp/libosmo-sccp_git.bb
+++ b/recipes-osmocom/libosmo-sccp/libosmo-sccp_git.bb
@@ -5,25 +5,3 @@ SRCREV = "58fcc5344ea0e914c7f9be69c309998d243142bd"
SRC_URI = "git://git.osmocom.org/libosmo-sccp.git;protocol=git"
PV = "0.8.1+gitr${SRCPV}"
PR = "${INC_PR}.0"
-
-# we require the tests to link to the static libosmo-sigtran library to
-# access symbols not starting with osmo_*
-EXTRA_OECONF_remove = "--disable-static"
-
-PACKAGES =+ "osmo-stp"
-SYSTEMD_PACKAGES = "osmo-stp"
-SYSTEMD_SERVICE_osmo-stp = "osmo-stp.service"
-
-do_install_append() {
- install -d ${D}${systemd_system_unitdir}/
- install -d ${D}${sysconfdir}/osmocom/
-
- install -m 0644 ${S}/doc/examples/osmo-stp.cfg ${D}${sysconfdir}/osmocom/
- install -m 0644 ${S}/contrib/systemd/osmo-stp.service ${D}${systemd_system_unitdir}/
-}
-
-FILES_osmo-stp = " \
- ${bindir}/osmo-stp \
- ${sysconfdir}/osmocom/osmo-stp.cfg \
- "
-CONFFILES_osmo-stp = "${sysconfdir}/osmocom/osmo-stp.cfg"