aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPau Espin Pedrol <pespin@sysmocom.de>2017-09-26 14:29:24 +0200
committerPau Espin Pedrol <pespin@sysmocom.de>2017-09-29 14:19:59 +0200
commit8554d8a42c0e2ed7f0e39ba76cd3aee78dde6f30 (patch)
tree0cb82c8de202814b47b03ece8a6b259d761669d2
parentb4eb971657d68322d11064e45012d2b4adf29e93 (diff)
osmo-hlr: Introduce recipe
-rw-r--r--recipes-osmocom/osmo-hlr/osmo-hlr.inc26
-rw-r--r--recipes-osmocom/osmo-hlr/osmo-hlr_git.bb7
2 files changed, 33 insertions, 0 deletions
diff --git a/recipes-osmocom/osmo-hlr/osmo-hlr.inc b/recipes-osmocom/osmo-hlr/osmo-hlr.inc
new file mode 100644
index 0000000..8afe774
--- /dev/null
+++ b/recipes-osmocom/osmo-hlr/osmo-hlr.inc
@@ -0,0 +1,26 @@
+DESCRIPTION = "Osmocom HLR implementation"
+HOMEPAGE = "https://osmocom.org/projects/osmo-hlr"
+LICENSE = "AGPLv3"
+LIC_FILES_CHKSUM = "file://COPYING;md5=73f1eb20517c55bf9493b7dd6e480788"
+
+DEPENDS = "libtalloc libosmocore libosmo-abis sqlite3 sqlite3-native"
+
+INC_PR="r0.${META_TELEPHONY_OSMO_INC}"
+
+inherit autotools pkgconfig systemd
+
+do_compile_append() {
+ sqlite3 ${WORKDIR}/hlr.db < ${S}/sql/hlr.sql
+}
+
+do_install_append() {
+ install -d ${D}${systemd_system_unitdir}/
+ install -d ${D}${sysconfdir}/osmocom/
+ install -d ${D}${localstatedir}/lib/osmocom/
+
+ install -m 0644 ${S}/doc/examples/osmo-hlr.cfg ${D}${sysconfdir}/osmocom/
+ install -m 0644 ${S}/contrib/systemd/osmo-hlr.service ${D}${systemd_system_unitdir}/
+ install -m 0644 ${WORKDIR}/hlr.db ${D}${localstatedir}/lib/osmocom/hlr.db
+}
+
+SYSTEMD_SERVICE_${PN} = "${PN}.service"
diff --git a/recipes-osmocom/osmo-hlr/osmo-hlr_git.bb b/recipes-osmocom/osmo-hlr/osmo-hlr_git.bb
new file mode 100644
index 0000000..8a08d94
--- /dev/null
+++ b/recipes-osmocom/osmo-hlr/osmo-hlr_git.bb
@@ -0,0 +1,7 @@
+require ${PN}.inc
+
+S = "${WORKDIR}/git"
+SRCREV = "05c8b465ab2fe13edb67c95210a9b475f91ebeb3"
+SRC_URI = "git://git.osmocom.org/osmo-hlr.git;protocol=git"
+PV = "0.0.1+gitr${SRCPV}"
+PR = "${INC_PR}.0"