aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOliver Smith <osmith@sysmocom.de>2021-02-09 11:47:52 +0100
committerPau Espin Pedrol <pespin@sysmocom.de>2021-02-24 17:03:45 +0100
commitef0667301a5e371fa59013299bf0cb89d8ba14d0 (patch)
treee5b711e6e28fb7064cf1dbad34cdc4ce30073f54
parent0734dc551b0f072007bd4082fef6a3b7c30a273c (diff)
Adjust to osmo-gbproxy split from osmo-sgsn
-rw-r--r--recipes-osmocom/osmo-gbproxy/osmo-gbproxy.inc19
-rw-r--r--recipes-osmocom/osmo-gbproxy/osmo-gbproxy_git.bb7
-rw-r--r--recipes-osmocom/osmo-sgsn/osmo-sgsn.inc12
3 files changed, 28 insertions, 10 deletions
diff --git a/recipes-osmocom/osmo-gbproxy/osmo-gbproxy.inc b/recipes-osmocom/osmo-gbproxy/osmo-gbproxy.inc
new file mode 100644
index 0000000..1add0b9
--- /dev/null
+++ b/recipes-osmocom/osmo-gbproxy/osmo-gbproxy.inc
@@ -0,0 +1,19 @@
+DESCRIPTION = "Osmocom's Gb interface aggregation/conversion proxy"
+HOMEPAGE = "https://osmocom.org/projects/osmo-gbproxy"
+LICENSE = "AGPLv3"
+LIC_FILES_CHKSUM = "file://COPYING;md5=73f1eb20517c55bf9493b7dd6e480788"
+
+DEPENDS = "libosmocore"
+
+INC_PR="r0.${META_TELEPHONY_OSMO_INC}"
+
+inherit autotools pkgconfig systemd
+
+PACKAGECONFIG ??= "\
+ ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)} \
+ "
+PACKAGECONFIG[systemd] = "--with-systemdsystemunitdir=${systemd_system_unitdir},--without-systemdsystemunitdir"
+
+SYSTEMD_SERVICE_osmo-gbproxy = "osmo-gbproxy.service"
+
+CONFFILES_osmo-gbproxy = "${sysconfdir}/osmocom/osmo-gbproxy.cfg"
diff --git a/recipes-osmocom/osmo-gbproxy/osmo-gbproxy_git.bb b/recipes-osmocom/osmo-gbproxy/osmo-gbproxy_git.bb
new file mode 100644
index 0000000..19e6b99
--- /dev/null
+++ b/recipes-osmocom/osmo-gbproxy/osmo-gbproxy_git.bb
@@ -0,0 +1,7 @@
+require ${PN}.inc
+
+S = "${WORKDIR}/git"
+SRCREV = "0.1.0"
+SRC_URI = "git://git.osmocom.org/osmo-gbproxy.git;protocol=git;tag=${SRCREV};nobranch=1"
+PV = "0.1.0+gitr${SRCPV}"
+PR = "${INC_PR}.0"
diff --git a/recipes-osmocom/osmo-sgsn/osmo-sgsn.inc b/recipes-osmocom/osmo-sgsn/osmo-sgsn.inc
index 57ab845..1f6fd7a 100644
--- a/recipes-osmocom/osmo-sgsn/osmo-sgsn.inc
+++ b/recipes-osmocom/osmo-sgsn/osmo-sgsn.inc
@@ -16,25 +16,17 @@ PACKAGECONFIG ??= "\
PACKAGECONFIG[systemd] = "--with-systemdsystemunitdir=${systemd_system_unitdir},--without-systemdsystemunitdir"
PACKAGECONFIG[iu] = "--enable-iu,--disable-iu,libasn1c libosmo-sccp osmo-iuh,"
-PACKAGES =+ "osmo-gbproxy-doc osmo-gtphub-doc osmo-gbproxy osmo-gtphub"
-SYSTEMD_PACKAGES = "osmo-sgsn osmo-gbproxy osmo-gtphub"
+PACKAGES =+ "osmo-gtphub-doc osmo-gtphub"
+SYSTEMD_PACKAGES = "osmo-sgsn osmo-gtphub"
SYSTEMD_SERVICE_osmo-sgsn = "osmo-sgsn.service"
-SYSTEMD_SERVICE_osmo-gbproxy = "osmo-gbproxy.service"
SYSTEMD_SERVICE_osmo-gtphub = "osmo-gtphub.service"
CONFFILES_osmo-sgsn = "${sysconfdir}/osmocom/osmo-sgsn.cfg"
-FILES_osmo-gbproxy = " \
- ${bindir}/osmo-gbproxy \
- ${sysconfdir}/osmocom/osmo-gbproxy.cfg \
- "
-CONFFILES_osmo-gbproxy = "${sysconfdir}/osmocom/osmo-gbproxy.cfg"
-
FILES_osmo-gtphub = " \
${bindir}/osmo-gtphub \
${sysconfdir}/osmocom/osmo-gtphub.cfg \
"
CONFFILES_osmo-gtphub = "${sysconfdir}/osmocom/osmo-gtphub.cfg"
-FILES_osmo-gbproxy-doc = " ${docdir}/osmo-sgsn/examples/osmo-gbproxy "
FILES_osmo-gtphub-doc = " ${docdir}/osmo-sgsn/examples/osmo-gtphub "