aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPau Espin Pedrol <pespin@sysmocom.de>2019-08-06 13:52:15 +0200
committerPau Espin Pedrol <pespin@sysmocom.de>2019-08-09 12:42:26 +0200
commit6b07fdc95d2be273d1add56a9590b6681f16ce7a (patch)
tree5827fb725c5dec296ee8933cc5a6f57307f88828
parent35dd98b6e95da53aaa21d2e00b627ebaedc42a15 (diff)
libosmocore: Disable TLS workaround to avoid ld crash
-rw-r--r--recipes-osmocom/libosmocore/libosmocore_git.bb12
1 files changed, 12 insertions, 0 deletions
diff --git a/recipes-osmocom/libosmocore/libosmocore_git.bb b/recipes-osmocom/libosmocore/libosmocore_git.bb
index 06e9796..3a417f0 100644
--- a/recipes-osmocom/libosmocore/libosmocore_git.bb
+++ b/recipes-osmocom/libosmocore/libosmocore_git.bb
@@ -24,3 +24,15 @@ RREPLACES_libosmogsm = "DONOTREPLACElibosmocore"
RREPLACES_libosmovty = "DONOTREPLACElibosmocore"
EXTRA_OECONF += "--disable-pcsc"
+
+# OS#4062: Some gcc version (< 7.3.0) on ARM generate wrong code for __thread
+# variables that crash at runtime. It seems, due to some unknown reason, that we
+# are not affected by this bug with toolchain from poky pyro (6.4.0). However,
+# libosmocore as of e188b8cd98f599468fbb200c7d590de955daf761 applies some
+# CFLAGS="-mtls-dialect=gnu2" to workaround the issue automatically. But same
+# toolchain contains an "ld" that crashes when those flags are applied.
+# Fortunately, libosmocore provides a way to disable the workaround, and since
+# we are not affected by the bug, we are fine with that. If the toolchain had
+# the TLS runtime bug, then we'd had to build with -O0. Can be probably dropped
+# once we move to newer toolchain.
+EXTRA_OECONF += "--disable-detect-tls-gcc-arm-bug"