aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOliver Smith <osmith@sysmocom.de>2022-03-02 11:32:59 +0100
committerPau Espin Pedrol <pespin@sysmocom.de>2022-06-29 13:12:02 +0200
commitc7b65fa9bea603763c73b636c1d9dbf9f90ce670 (patch)
treeb52add2f03711d0fd518b69299257664ada8ab51
parent400e358be455cfdbe0c40e1d19d1dd6f3292d539 (diff)
osmo-ggsn: update libgtp-queue_depth_32.patch
Adjust to change in osmo-ggsn I6034b0fab2b2e5962314c2fca2f893246ce5cf4f ("libgtp: Define retransmit QUEUE_SIZE relative to PDP_MAX (increase)"). Set it to 128, as Pau suggested. Fix for: Applying patch libgtp-queue_depth_32.patch patching file gtp/queue.h Hunk #1 FAILED at 19. Change-Id: Ib8803fba7d1308042d12186009344b2a61abb6e3
-rw-r--r--recipes-osmocom/osmo-ggsn/files/0001-libgtp-set-PDP_MAX-to-128.patch34
-rw-r--r--recipes-osmocom/osmo-ggsn/files/libgtp-queue_depth_32.patch13
-rw-r--r--recipes-osmocom/osmo-ggsn/osmo-ggsn_git.bb4
3 files changed, 36 insertions, 15 deletions
diff --git a/recipes-osmocom/osmo-ggsn/files/0001-libgtp-set-PDP_MAX-to-128.patch b/recipes-osmocom/osmo-ggsn/files/0001-libgtp-set-PDP_MAX-to-128.patch
new file mode 100644
index 0000000..53ac7ef
--- /dev/null
+++ b/recipes-osmocom/osmo-ggsn/files/0001-libgtp-set-PDP_MAX-to-128.patch
@@ -0,0 +1,34 @@
+From 2e0112520892b8f6a794c16bf3d025a7d10a89a5 Mon Sep 17 00:00:00 2001
+From: Oliver Smith <osmith@sysmocom.de>
+Date: Wed, 2 Mar 2022 11:24:31 +0100
+Subject: [PATCH] libgtp: set PDP_MAX to 128
+
+Reduce PDP_MAX and therefore QUEUE_SIZE (which is PDP_MAX * 2, see
+gtp/queue.h). Harald explained why:
+
+ libgtp statically allocates immensely large queues for packet
+ re-transmissions by default, way too much to run OsmoSGSN or
+ OpenGGSN/OsmoGGSN on the small ARM926EJS of sysmoBTS 1002.
+
+Related: https://gerrit.osmocom.org/c/meta-telephony/+/4092/2#message-8ec2174fac6c0bf3d9aab1270a7ebe06955d3bea
+Change-Id: I97d5db8f2def4d628a6c4e67c27f07c7200b94d4
+---
+ gtp/pdp.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/gtp/pdp.h b/gtp/pdp.h
+index 4dcdde46..9587f31e 100644
+--- a/gtp/pdp.h
++++ b/gtp/pdp.h
+@@ -24,7 +24,7 @@ struct gsn_t;
+ #define LOGPDPX(ss, level, pdp, fmt, args...) \
+ LOGP(ss, level, "PDP(%s:%u): " fmt, imsi_gtp2str(&(pdp)->imsi), (pdp)->nsapi, ## args)
+
+-#define PDP_MAX 1024 /* Max number of PDP contexts */
++#define PDP_MAX 128 /* Max number of PDP contexts */
+ #define PDP_MAXNSAPI 16 /* Max number of NSAPI */
+
+ #define PDP_EUA_ORG_IETF 0xF1
+--
+2.30.2
+
diff --git a/recipes-osmocom/osmo-ggsn/files/libgtp-queue_depth_32.patch b/recipes-osmocom/osmo-ggsn/files/libgtp-queue_depth_32.patch
deleted file mode 100644
index 52bc37b..0000000
--- a/recipes-osmocom/osmo-ggsn/files/libgtp-queue_depth_32.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/gtp/queue.h b/gtp/queue.h
-index 556b6ef..d59a1a3 100644
---- a/gtp/queue.h
-+++ b/gtp/queue.h
-@@ -19,7 +19,7 @@
-
- #define QUEUE_DEBUG 0 /* Print debug information */
-
--#define QUEUE_SIZE 1024 /* Size of retransmission queue */
-+#define QUEUE_SIZE 32 /* Size of retransmission queue */
- #define QUEUE_HASH_SIZE 65536 /* Size of hash table (2^16) */
-
- struct qmsg_t { /* Holder for queued packets */
diff --git a/recipes-osmocom/osmo-ggsn/osmo-ggsn_git.bb b/recipes-osmocom/osmo-ggsn/osmo-ggsn_git.bb
index 5498d3d..8c63418 100644
--- a/recipes-osmocom/osmo-ggsn/osmo-ggsn_git.bb
+++ b/recipes-osmocom/osmo-ggsn/osmo-ggsn_git.bb
@@ -3,7 +3,7 @@ require ${PN}.inc
S = "${WORKDIR}/git"
SRCREV = "1.8.0"
SRC_URI = "git://git.osmocom.org/osmo-ggsn;protocol=git;tag=${SRCREV};nobranch=1 \
- file://libgtp-queue_depth_32.patch \
+ file://0001-libgtp-set-PDP_MAX-to-128.patch \
"
PV = "1.8.0+gitr${SRCPV}"
-PR = "${INC_PR}.0"
+PR = "${INC_PR}.1"