aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPau Espin Pedrol <pespin@sysmocom.de>2017-07-21 13:37:18 +0200
committerPau Espin Pedrol <pespin@sysmocom.de>2019-07-18 17:43:51 +0200
commit4b85e1a2bbdb64b59a8da4a1bd314c6157173cfb (patch)
treeefd96db006e5297374a8354ee9fb920c95af7f2a
parent581a3363bcfaad507a8f4b127ff18c687ad5388d (diff)
Add recipe for osmo-pcap, both server and client
-rw-r--r--recipes-osmocom/osmo-pcap/osmo-pcap.inc39
-rw-r--r--recipes-osmocom/osmo-pcap/osmo-pcap_git.bb7
2 files changed, 46 insertions, 0 deletions
diff --git a/recipes-osmocom/osmo-pcap/osmo-pcap.inc b/recipes-osmocom/osmo-pcap/osmo-pcap.inc
new file mode 100644
index 0000000..a7d3a60
--- /dev/null
+++ b/recipes-osmocom/osmo-pcap/osmo-pcap.inc
@@ -0,0 +1,39 @@
+DESCRITOPN = "Osmocom PCAP client (probe) and server (aggregator)"
+HOMEPAGE = "https://osmocom.org/"
+LICENSE = "AGPLv3+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=73f1eb20517c55bf9493b7dd6e480788"
+
+DEPENDS = "libosmocore zeromq libpcap gnutls"
+
+INC_PR="r0.${META_TELEPHONY_OSMO_INC}"
+
+inherit autotools pkgconfig systemd
+
+PACKAGECONFIG ??= "\
+ ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)} \
+ "
+PACKAGECONFIG[systemd] = "--with-systemdsystemunitdir=${systemd_system_unitdir},--without-systemdsystemunitdir"
+
+PACKAGES =+ "osmo-pcap-server osmo-pcap-client"
+
+SYSTEMD_PACKAGES = "osmo-pcap-server osmo-pcap-client"
+SYSTEMD_SERVICE_osmo-pcap-server = "osmo-pcap-server.service"
+SYSTEMD_SERVICE_osmo-pcap-client = "osmo-pcap-client.service"
+
+CONFFILES_osmo-pcap-server = "${sysconfdir}/osmocom/osmo-pcap-server.cfg"
+CONFFILES_osmo-pcap-client = "${sysconfdir}/osmocom/osmo-pcap-client.cfg"
+
+EXTRA_OECONF += "--with-pcap-config=no"
+
+do_configure_prepend() {
+ export PCAP_LIBS="-lpcap"
+}
+
+FILES_osmo-pcap-server = "${bindir}/osmo-pcap-server \
+ ${sysconfdir}/osmocom/osmo-pcap-server.cfg \
+ ${datadir}/osmo-pcap/osmo_pcap_clean_old \
+ "
+
+FILES_osmo-pcap-client = "${bindir}/osmo-pcap-client \
+ ${sysconfdir}/osmocom/osmo-pcap-client.cfg \
+ "
diff --git a/recipes-osmocom/osmo-pcap/osmo-pcap_git.bb b/recipes-osmocom/osmo-pcap/osmo-pcap_git.bb
new file mode 100644
index 0000000..9ffb510
--- /dev/null
+++ b/recipes-osmocom/osmo-pcap/osmo-pcap_git.bb
@@ -0,0 +1,7 @@
+require ${PN}.inc
+
+S = "${WORKDIR}/git"
+SRCREV = "901543a78846cc4e3a0cdae91dead4913b1be961"
+SRC_URI = "git://git.osmocom.org/osmo-pcap.git;protocol=git"
+PV = "0.1.0+gitr${SRCPV}"
+PR = "${INC_PR}.0"