aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabio Berton <fabio.berton@ossystems.com.br>2015-10-15 14:56:07 -0300
committerFabio Berton <fabio.berton@ossystems.com.br>2015-10-26 13:23:34 -0200
commit23399a4592d7bbfe2c9361ff3bef899709eba4bf (patch)
treea667855e560a8efe7c43cc5a007373fa4c695f6f
parenta1debd963cd2a0d24eaaddc661c109ab02ed3cba (diff)
dahdi-tools: Organize recipe
Fix indentations and style issues. Signed-off-by: Fabio Berton <fabio.berton@ossystems.com.br>
-rw-r--r--recipes-isdn/dahdi-tools/dahdi-tools_2.6.0.bb45
1 files changed, 25 insertions, 20 deletions
diff --git a/recipes-isdn/dahdi-tools/dahdi-tools_2.6.0.bb b/recipes-isdn/dahdi-tools/dahdi-tools_2.6.0.bb
index 06ef35c..2b26b27 100644
--- a/recipes-isdn/dahdi-tools/dahdi-tools_2.6.0.bb
+++ b/recipes-isdn/dahdi-tools/dahdi-tools_2.6.0.bb
@@ -1,36 +1,41 @@
DESCRITOPN = "Utilities for the DAHDI Asterisk Linux kernel drivers"
-DEPENDS = "dahdi-linux libnewt libpcap"
-RDEPENDS_${PN} += "perl perl-module-strict perl-module-file-basename perl-module-config \
- perl-module-warnings perl-module-getopt perl-module-getopt-std \
- perl-module-file perl-module-file-glob perl-module-xsloader \
- perl-module-dynaloader perl-module-carp perl-module-errno"
-
HOMEPAGE = "http://www.asterisk.org"
LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "\
+ file://LICENSE;md5=ea5bed2f60d357618ca161ad539f7c0a \
+ file://LICENSE.LGPL;md5=fb504b67c50331fc78734fed90fb0e09 \
+"
-SRC_URI = "http://downloads.asterisk.org/pub/telephony/dahdi-tools/releases/dahdi-tools-${PV}.tar.gz \
- file://perl_install.patch "
-
-INC_PR="r19"
-
-LIC_FILES_CHKSUM = "file://LICENSE;md5=ea5bed2f60d357618ca161ad539f7c0a \
- file://LICENSE.LGPL;md5=fb504b67c50331fc78734fed90fb0e09"
+DEPENDS = "dahdi-linux libnewt libpcap"
-FILES_${PN} += "${datadir}/dahdi"
+SRC_URI = "\
+ http://downloads.asterisk.org/pub/telephony/dahdi-tools/releases/dahdi-tools-${PV}.tar.gz \
+ file://perl_install.patch \
+"
inherit autotools_stage pkgconfig perlnative cpan-base
+export DAHDI_PERLLIBDIR="${PERLLIBDIRS}/${@get_perl_version(d)}"
+
do_configure() {
- oe_runconf
+ oe_runconf
}
do_compile() {
- base_do_compile
- oe_runmake dahdi_pcap
+ base_do_compile
+ oe_runmake dahdi_pcap
}
-export DAHDI_PERLLIBDIR="${PERLLIBDIRS}/${@get_perl_version(d)}"
do_install() {
- autotools_do_install
- install -m 755 ${S}/dahdi_pcap ${D}${sbindir}/
+ autotools_do_install
+ install -m 755 ${S}/dahdi_pcap ${D}${sbindir}/
}
+
+FILES_${PN} += "${datadir}/dahdi"
+
+RDEPENDS_${PN} += "\
+ perl perl-module-strict perl-module-file-basename perl-module-config \
+ perl-module-warnings perl-module-getopt perl-module-getopt-std \
+ perl-module-file perl-module-file-glob perl-module-xsloader \
+ perl-module-dynaloader perl-module-carp perl-module-errno \
+"