aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2010-07-09 20:57:43 +0200
committerHarald Welte <laforge@gnumonks.org>2010-07-09 20:57:43 +0200
commit3dc72b8cff16ffcc9babab9a9892befda44d8c4e (patch)
treef58253ec5c8a39d8215dacaf8a31297fbe5811e2 /configure.in
parent7e7186ca00b33e9735c809ce200e310636006a22 (diff)
update to sualibrary-0.1.2 from 2002-11-26
* Contains Relaying functionality using hostnames. * Correct some bugs * Compiles and runs on Linux, FreeBSD, Max OS X .... * Tested on IPv4 and IPV6 networks * interoperable with other SUA implementations * corresponds to sua draft v13 * requires SCTP implementation sctplib-1.0.0-pre19 from www.sctp.de
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in104
1 files changed, 52 insertions, 52 deletions
diff --git a/configure.in b/configure.in
index 37405e5..9299100 100644
--- a/configure.in
+++ b/configure.in
@@ -8,7 +8,7 @@ AC_INIT(acconfig.h)
AC_CANONICAL_SYSTEM
AC_ARG_PROGRAM
-AM_INIT_AUTOMAKE(sualibrary,0.1.0)
+AM_INIT_AUTOMAKE(sualibrary,0.1.2)
AC_PREFIX_DEFAULT(/usr/local)
if test "x$prefix" = "xNONE"; then
@@ -16,10 +16,10 @@ if test "x$prefix" = "xNONE"; then
ac_configure_args="$ac_configure_args --prefix $prefix"
fi
-dnl keep this order because automake gets confused apart from the authors
+# keep this order because automake gets confused apart from the authors
AM_CONFIG_HEADER(config.h:config.h.in)
-dnl Checks for programs.
+# Checks for programs.
AC_PROG_AWK
AC_PROG_CC
AC_PROG_INSTALL
@@ -28,23 +28,23 @@ AC_PROG_CXX
AC_PROG_RANLIB
-dnl Checks for libraries.
-dnl create only shared libtool-libraries (add --enable-shared)
+# Checks for libraries.
+# create only shared libtool-libraries (add --enable-shared)
AC_ENABLE_SHARED(no)
-dnl AM_DISABLE_SHARED
+# AM_DISABLE_SHARED
-dnl set the following to yes, if you want to create static
-dnl libtool-libraries, else no
+# set the following to yes, if you want to create static
+# libtool-libraries, else no
AC_ENABLE_STATIC(yes)
-dnl create a working libtool-script
+# create a working libtool-script
if test -z "$LIBTOOL"; then
AC_LANG_SAVE
AC_LANG_CPLUSPLUS
AC_LIBTOOL_DLOPEN
AM_PROG_LIBTOOL
- dnl LIBTOOL="$LIBTOOL --silent"
- dnl AC_SUBST(LIBTOOL)
+ # LIBTOOL="$LIBTOOL --silent"
+ # AC_SUBST(LIBTOOL)
AC_LANG_RESTORE
LIBTOOL_SHELL='/bin/sh ./libtool'
else
@@ -52,8 +52,8 @@ else
fi
-dnl activate the following for some additional tests
-dnl (compat, crypt, socket, nsl, ...)
+# activate the following for some additional tests
+# (compat, crypt, socket, nsl, ...)
all_libraries="$USER_LDFLAGS $all_libraries"
all_includes="$all_includes $USER_INCLUDES"
@@ -61,7 +61,7 @@ AC_SUBST(all_includes)
AC_SUBST(all_libraries)
AC_SUBST(AUTODIRS)
-dnl Checks for header files.
+# Checks for header files.
AC_HEADER_STDC
AC_HEADER_TIME
@@ -70,24 +70,24 @@ sys/socket.h netinet/icmp6.h)
AC_CHECK_HEADERS(sys/poll.h, AC_DEFINE(HAVE_SYS_POLL_H))
-dnl Checks for typedefs, structures, and compiler characteristics.
+# Checks for typedefs, structures, and compiler characteristics.
-dnl ----------------------
-dnl Packages configuration - Blatantly stolen from zebra !
-dnl ----------------------
+# ----------------------
+# Packages configuration - Blatantly stolen from zebra !
+# ----------------------
AC_ARG_ENABLE(ipv6,
[ --disable-ipv6 turn off IPv6 support ])
-dnl ----------
-dnl IPv6 check
-dnl ----------
+# ----------
+# IPv6 check
+# ----------
AC_MSG_CHECKING(whether this OS does have IPv6 stack)
if test "${enable_ipv6}" = "no"; then
AC_MSG_RESULT(disabled)
else
-dnl ----------
-dnl INRIA IPv6
-dnl ----------
+# ----------
+# INRIA IPv6
+# ----------
if grep IPV6_INRIA_VERSION /usr/include/netinet/in.h >/dev/null 2>&1; then
cv_ipv6=yes
AC_DEFINE(HAVE_IPV6)
@@ -95,9 +95,9 @@ if grep IPV6_INRIA_VERSION /usr/include/netinet/in.h >/dev/null 2>&1; then
LIB_IPV6=""
AC_MSG_RESULT(INRIA IPv6)
fi
-dnl ---------
-dnl KAME IPv6
-dnl ---------
+# ---------
+# KAME IPv6
+# ---------
if grep WIDE /usr/include/netinet6/in6.h >/dev/null 2>&1; then
cv_ipv6=yes
AC_DEFINE(HAVE_IPV6)
@@ -107,9 +107,9 @@ if grep WIDE /usr/include/netinet6/in6.h >/dev/null 2>&1; then
fi
AC_MSG_RESULT(KAME)
fi
-dnl ---------
-dnl NRL check
-dnl ---------
+# ---------
+# NRL check
+# ---------
if grep NRL /usr/include/netinet6/in6.h >/dev/null 2>&1; then
cv_ipv6=yes
AC_DEFINE(HAVE_IPV6)
@@ -121,11 +121,11 @@ if grep NRL /usr/include/netinet6/in6.h >/dev/null 2>&1; then
AC_MSG_RESULT(NRL)
fi
fi
-dnl ----------
-dnl Linux IPv6
-dnl ----------
+# ----------
+# Linux IPv6
+# ----------
if test "${enable_ipv6}" = "yes"; then
- AC_EGREP_CPP(yes, [dnl
+ AC_EGREP_CPP(yes, [#
#include <linux/version.h>
/* 2.1.128 or later */
#if LINUX_VERSION_CODE >= 0x020180
@@ -159,15 +159,15 @@ fi
fi
-dnl -----------------------
-dnl Set IPv6 related values
-dnl -----------------------
+# -----------------------
+# Set IPv6 related values
+# -----------------------
LIBS="$LIB_IPV6 $LIBS"
AC_SUBST(LIB_IPV6)
-dnl -----------------------------------
-dnl check sin6_scope_id of sockaddr_in6
-dnl -----------------------------------
+# -----------------------------------
+# check sin6_scope_id of sockaddr_in6
+# -----------------------------------
if test "$cv_ipv6" = yes; then
AC_MSG_CHECKING(whether struct sockaddr_in6 has a sin6_scope_id field)
AC_TRY_COMPILE([#include <sys/types.h>
@@ -178,9 +178,9 @@ if test "$cv_ipv6" = yes; then
AC_MSG_RESULT(no))
fi
-dnl -----------------------------------
-dnl Check for New Socket API (RFC2292BIS)
-dnl -----------------------------------
+# -----------------------------------
+# Check for New Socket API (RFC2292BIS)
+# -----------------------------------
AC_MSG_CHECKING(for rfc2292bis support)
AC_TRY_COMPILE([#include <sys/types.h>
#include <netinet/in.h>],
@@ -198,9 +198,9 @@ AC_TRY_COMPILE([#include <sys/types.h>
AC_MSG_RESULT(yes)],
[AC_MSG_RESULT(no)])
-dnl This is taken from the ethereal configuration scripts.
-dnl We check whether user wants to build gtk-based programs
-dnl These need to be enabled explicitly
+# This is taken from the ethereal configuration scripts.
+# We check whether user wants to build gtk-based programs
+# These need to be enabled explicitly
GTK_OK=yes
# GTK checks
@@ -236,12 +236,12 @@ AM_PATH_GLIB(1.2.0, CFLAGS="$CFLAGS $GLIB_CFLAGS", AC_MSG_ERROR(GLib distributio
AC_SUBST(sctp_SUBDIRS)
-dnl Checks for library functions.
+# Checks for library functions.
AC_CHECK_LIB(socket, socket)
AC_CHECK_LIB(nsl, gethostbyname)
AC_CHECK_LIB(sctp, sctp_eventloop)
-dnl removed libefence....this should be used though, when we REALLY debug :-)
+# removed libefence....this should be used though, when we REALLY debug :-)
AC_CHECK_LIB(efence, malloc)
AC_CHECK_LIB(glib, g_main_add_poll)
@@ -287,14 +287,14 @@ AC_CHECK_LIB(c, inet_ntop, [AC_DEFINE(HAVE_INET_NTOP)])
AC_CHECK_LIB(c, inet_pton, [AC_DEFINE(HAVE_INET_PTON)])
AC_CHECK_LIB(c, inet_aton, [AC_DEFINE(HAVE_INET_ATON)])
-dnl Checks for library functions.
+# Checks for library functions.
AC_FUNC_VPRINTF
AC_FUNC_MEMCMP
AC_CHECK_FUNCS(gettimeofday socket strerror poll getuid setuid geteuid random)
AC_CHECK_FUNCS(getaddrinfo, [have_getaddrinfo=yes], [have_getaddrinfo=no])
-dnl checks for host/build/target system type
+# checks for host/build/target system type
AC_CANONICAL_HOST
case $host_os in
bsdi*)
@@ -356,7 +356,7 @@ AC_SUBST(thread_LIBS)
-dnl Checks for typedefs, structures, and compiler characteristics.
+# Checks for typedefs, structures, and compiler characteristics.
AC_C_CONST
AC_TYPE_SIZE_T
AC_STRUCT_TM
@@ -379,5 +379,5 @@ AC_TRY_COMPILE([#include <sys/types.h>
-dnl add here all your Makefiles. These will be created by configure
+# add here all your Makefiles. These will be created by configure
AC_OUTPUT(Makefile sualibrary/Makefile sualibrary/docs/Makefile sualibrary/docs/en/Makefile sualibrary/sua/Makefile sualibrary/testup/Makefile )