aboutsummaryrefslogtreecommitdiffstats
path: root/include/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'include/Makefile.am')
-rw-r--r--include/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/include/Makefile.am b/include/Makefile.am
index 0a300a84..770a9c62 100644
--- a/include/Makefile.am
+++ b/include/Makefile.am
@@ -143,3 +143,9 @@ osmocom/core/bit%gen.h: osmocom/core/bitXXgen.h.tpl
osmocom/core/crc%gen.h: osmocom/core/crcXXgen.h.tpl
$(AM_V_GEN)$(MKDIR_P) $(dir $@)
$(AM_V_GEN)sed -e's/XX/$*/g' $< > $@
+
+osmocom/gsm/gsm0503.h:
+ $(AM_V_GEN)python2 $(top_srcdir)/utils/conv_gen.py gen_header gsm \
+ --target-path $(top_srcdir)/include/osmocom/gsm/
+
+CLEANFILES = osmocom/gsm/gsm0503.h