aboutsummaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules23
1 files changed, 18 insertions, 5 deletions
diff --git a/debian/rules b/debian/rules
index a9d961c7..db97497c 100755
--- a/debian/rules
+++ b/debian/rules
@@ -25,8 +25,20 @@ override_dh_install:
override_dh_auto_test:
dh_auto_test || (find . -name testsuite.log -exec cat {} \; ; false)
+# Set --disable-uring for debian 10 and ubuntu 20.04
override_dh_auto_configure:
- dh_auto_configure -- --enable-static
+ set -x && \
+ CONFIGURE_FLAGS=" \
+ --disable-sctp-tests \
+ --disable-uring-tests \
+ --enable-static \
+ --enable-systemd-logging \
+ "; \
+ distro_v=$$(. /etc/os-release && echo $$VERSION_ID); \
+ if [ "$$distro_v" = 10 ] || [ "$$distro_v" = 20.04 ]; then \
+ CONFIGURE_FLAGS="$$CONFIGURE_FLAGS --disable-uring"; \
+ fi; \
+ dh_auto_configure -- $$CONFIGURE_FLAGS
override_dh_clean:
dh_clean
@@ -40,16 +52,17 @@ override_dh_clean:
$(RM) include/osmocom/core/crc32gen.h
$(RM) include/osmocom/core/crc64gen.h
$(RM) include/osmocom/core/crc8gen.h
- $(RM) src/crc16gen.c
- $(RM) src/crc32gen.c
- $(RM) src/crc64gen.c
- $(RM) src/crc8gen.c
+ $(RM) src/core/crc16gen.c
+ $(RM) src/core/crc32gen.c
+ $(RM) src/core/crc64gen.c
+ $(RM) src/core/crc8gen.c
$(RM) tests/package.m4
$(RM) tests/testsuite
$(RM) -r doc/codec/
$(RM) -r doc/core/
$(RM) -r doc/ctrl/
$(RM) -r doc/gsm/
+ $(RM) -r doc/isdn/
$(RM) -r doc/gb/
$(RM) -r doc/vty/html/
$(RM) -r doc/vty/latex/