aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 6 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 80e2bccb..ef74932b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -84,13 +84,15 @@ AC_CONFIG_HEADER(config.h)
AC_ARG_ENABLE([pcsc], [AS_HELP_STRING([--disable-pcsc], [Build without PC/SC support])],
[
- osmo_ac_have_pcsc=$enableval
+ enable_pcsc=$enableval
],
[
- PKG_CHECK_MODULES(PCSC, libpcsclite)
- osmo_ac_have_pcsc="yes"
+ enable_pcsc="yes"
])
-AM_CONDITIONAL(ENABLE_PCSC, test "x$osmo_ac_have_pcsc" = "xyes")
+if test "x$enable_pcsc" = "xyes" ; then
+ PKG_CHECK_MODULES(PCSC, libpcsclite)
+fi
+AM_CONDITIONAL(ENABLE_PCSC, test "x$enable_pcsc" = "xyes")
AC_ARG_ENABLE(talloc,
[AS_HELP_STRING(