aboutsummaryrefslogtreecommitdiffstats
path: root/utils/Makefile.am
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2011-12-07 02:38:42 +0100
committerHarald Welte <laforge@gnumonks.org>2011-12-07 02:38:42 +0100
commit915e0ef5e7d21c5c3000c20b0f4846a2bb26843e (patch)
treec90d8556cecbf51487f94f296bd00aea3db645df /utils/Makefile.am
parent4afdd5dca21c323675e193d73457fc2cb0f1cecc (diff)
add 'osmo-auc-gen' tool that can be used to generate auth vectors
Thsi tool usses libosmocore in order to generate 2G and 3G authentication vectors from private key material, exactly like an AuC would produce them in a real network.
Diffstat (limited to 'utils/Makefile.am')
-rw-r--r--utils/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/utils/Makefile.am b/utils/Makefile.am
index 22903d97..4e7869e4 100644
--- a/utils/Makefile.am
+++ b/utils/Makefile.am
@@ -1,7 +1,10 @@
if ENABLE_UTILITIES
INCLUDES = $(all_includes) -I$(top_srcdir)/include
-noinst_PROGRAMS = osmo-arfcn
+noinst_PROGRAMS = osmo-arfcn osmo-auc-gen
osmo_arfcn_SOURCES = osmo-arfcn.c
osmo_arfcn_LDADD = $(top_builddir)/src/libosmocore.la $(top_builddir)/src/gsm/libosmogsm.la
+
+osmo_auc_gen_SOURCES = osmo-auc-gen.c
+osmo_auc_gen_LDADD = $(top_builddir)/src/libosmocore.la $(top_builddir)/src/gsm/libosmogsm.la
endif