aboutsummaryrefslogtreecommitdiffstats
path: root/utils/Makefile.am
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2018-09-25 16:34:19 +0200
committerHarald Welte <laforge@gnumonks.org>2018-09-25 20:05:02 +0200
commit81bfef931a35771bcf1b7164b3370ae851821678 (patch)
tree25cb5c0564da36c86ba2a6664d1b1cf9fcde200c /utils/Makefile.am
parent8515d035ae09edf3ad4d6e0dcbe526eee8bce3eb (diff)
Add new osmo-config-merge utility
This utility allows you to merge an incremental config "patch" into an osmocom-style config file. The patch file follows the same syntax as the original config file. It works by appending the leaf nodes of the patch file to the respective nodes of the input config file. This process allows configuration file changes/updates to be performed in a more stable/reliable way than by means of [unified] diff files, as they break every time the context lines break. osmo-config-merge doesn't suffer from this problem, as it understands the tree-like nature of VTY config files. NITE: This only works with configuration files that have proper indenting, i.e. every level in the hierarchy must be indented excatly one character, not multiple. Change-Id: I61997a3668cc3a40d12ca023272f6d782e6fbefe
Diffstat (limited to 'utils/Makefile.am')
-rw-r--r--utils/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/utils/Makefile.am b/utils/Makefile.am
index d4999bde..fb791906 100644
--- a/utils/Makefile.am
+++ b/utils/Makefile.am
@@ -5,12 +5,16 @@ LDADD = $(top_builddir)/src/libosmocore.la $(top_builddir)/src/gsm/libosmogsm.la
EXTRA_DIST = conv_gen.py conv_codes_gsm.py
-bin_PROGRAMS = osmo-arfcn osmo-auc-gen
+bin_PROGRAMS = osmo-arfcn osmo-auc-gen osmo-config-merge
osmo_arfcn_SOURCES = osmo-arfcn.c
osmo_auc_gen_SOURCES = osmo-auc-gen.c
+osmo_config_merge_SOURCES = osmo-config-merge.c
+osmo_config_merge_LDADD = $(LDADD) $(TALLOC_LIBS)
+osmo_config_merge_CFLAGS = $(TALLOC_CFLAGS)
+
if ENABLE_PCSC
noinst_PROGRAMS = osmo-sim-test
osmo_sim_test_SOURCES = osmo-sim-test.c