aboutsummaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <holger@moiji-mobile.com>2014-01-02 13:55:00 +0100
committerHolger Hans Peter Freyther <holger@moiji-mobile.com>2014-01-02 13:59:10 +0100
commitb79a148eca01ff8f101662f389b8032ea2d9a535 (patch)
tree0696169aab1d3f3e7674ef54c929a7eb3443b678 /tests/Makefile.am
parentb7d0f4686b4aa55fd9b69884e6cc0c4c79ea1cd5 (diff)
utils: Add a simple testcase for osmo_hexdump
This code makes a simple dump and tests for the corner case
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 98ede3b8..c6216d50 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -7,12 +7,15 @@ check_PROGRAMS = timer/timer_test sms/sms_test ussd/ussd_test \
gb/bssgp_fc_test gb/gprs_ns_test \
logging/logging_test fr/fr_test \
loggingrb/loggingrb_test strrb/strrb_test \
- vty/vty_test comp128/comp128_test
+ vty/vty_test comp128/comp128_test utils/utils_test
if ENABLE_MSGFILE
check_PROGRAMS += msgfile/msgfile_test
endif
+utils_utils_test_SOURCES = utils/utils_test.c
+utils_utils_test_LDADD = $(top_builddir)/src/libosmocore.la
+
a5_a5_test_SOURCES = a5/a5_test.c
a5_a5_test_LDADD = $(top_builddir)/src/libosmocore.la $(top_builddir)/src/gsm/libosmogsm.la
@@ -104,7 +107,8 @@ EXTRA_DIST = testsuite.at $(srcdir)/package.m4 $(TESTSUITE) \
logging/logging_test.ok logging/logging_test.err \
fr/fr_test.ok loggingrb/logging_test.ok \
loggingrb/logging_test.err strrb/strrb_test.ok \
- vty/vty_test.ok comp128/comp128_test.ok
+ vty/vty_test.ok comp128/comp128_test.ok \
+ utils/utils_test.ok
DISTCLEANFILES = atconfig