aboutsummaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorOliver Smith <osmith@sysmocom.de>2019-12-11 08:46:41 +0100
committerosmith <osmith@sysmocom.de>2019-12-12 09:24:04 +0000
commita47d37c94684ba688a6eec06d0346ee13b03aad4 (patch)
treebf9375f3fcfb11d194955f684f241a3949788a82 /tests/Makefile.am
parent87b51439c1ba16e50e5a58d277d8de12d7109145 (diff)
debian, utils: switch to python 3
Make build and external tests work with python3, so we can drop the python2 dependency. This should be merged shortly after osmo-python-tests was migrated to python3, and the jenkins build slaves were (automatically) updated to have the new osmo-python-tests installed. Related: OS#2819 Depends: osmo-python-tests I3ffc3519bf6c22536a49dad7a966188ddad351a7 Change-Id: I84ef43f700e125c7a65f92347f12844e07e65655
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index e8e4dee1..3a3ea376 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -362,7 +362,7 @@ $(TESTSUITE): $(srcdir)/testsuite.at $(srcdir)/package.m4
mv $@.tmp $@
conv/gsm0503_test_vectors.c: $(top_srcdir)/utils/conv_gen.py $(top_srcdir)/utils/conv_codes_gsm.py
- $(AM_V_GEN)python $(top_srcdir)/utils/conv_gen.py gen_vectors gsm \
+ $(AM_V_GEN)python3 $(top_srcdir)/utils/conv_gen.py gen_vectors gsm \
--target-path $(builddir)/conv
if ENABLE_EXT_TESTS