aboutsummaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <zecke@selfish.org>2012-11-11 14:21:26 +0100
committerHolger Hans Peter Freyther <zecke@selfish.org>2013-01-15 20:06:40 +0100
commit97602d973457a5248ada6ca9e5c29c1a5811240d (patch)
tree3de3619f51a42d3f7e3df539d0068a942b316db6 /tests/Makefile.am
parente04a14d9a23ed42178c405cb0c0afb9a2d2b93ab (diff)
fr: Begin with a GRE/FrameRelay test due the recent regression
The framerelay code is seldomly used and the socket clean ups introduced a regression. Create a testcase that will work as a user not having the right capabilities to create raw sockets. We have to make sure that this test is working even when not ran as root. The easiest way to do this is to provide our own socket implementation. This is done with dlopen/dlsym to convert the raw socket request to an UDP one.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am9
1 files changed, 7 insertions, 2 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index b60f6758..be0b5f4c 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -4,7 +4,7 @@ check_PROGRAMS = timer/timer_test sms/sms_test ussd/ussd_test \
smscb/smscb_test bits/bitrev_test a5/a5_test \
conv/conv_test auth/milenage_test lapd/lapd_test \
gsm0808/gsm0808_test gsm0408/gsm0408_test \
- gb/bssgp_fc_test logging/logging_test
+ gb/bssgp_fc_test logging/logging_test fr/fr_test
if ENABLE_MSGFILE
check_PROGRAMS += msgfile/msgfile_test
endif
@@ -51,6 +51,10 @@ gb_bssgp_fc_test_LDADD = $(top_builddir)/src/libosmocore.la $(top_builddir)/src/
logging_logging_test_SOURCES = logging/logging_test.c
logging_logging_test_LDADD = $(top_builddir)/src/libosmocore.la
+fr_fr_test_SOURCES = fr/fr_test.c
+fr_fr_test_LDADD = $(top_builddir)/src/libosmocore.la $(top_builddir)/src/gb/libosmogb.la
+
+
# The `:;' works around a Bash 3.2 bug when the output is not writeable.
$(srcdir)/package.m4: $(top_srcdir)/configure.ac
:;{ \
@@ -77,7 +81,8 @@ EXTRA_DIST = testsuite.at $(srcdir)/package.m4 $(TESTSUITE) \
gsm0808/gsm0808_test.ok gb/bssgp_fc_tests.err \
gb/bssgp_fc_tests.ok gb/bssgp_fc_tests.sh \
msgfile/msgfile_test.ok msgfile/msgconfig.cfg \
- logging/logging_test.ok logging/logging_test.err
+ logging/logging_test.ok logging/logging_test.err \
+ fr/fr_test.ok
DISTCLEANFILES = atconfig