aboutsummaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2012-09-07 10:23:44 +0200
committerHarald Welte <laforge@gnumonks.org>2012-09-07 12:07:54 +0200
commit57e5b94e905b493ba2290109a79bf860c80e6055 (patch)
tree836183c1c34389f6fe0546fc90c93d7630f66257 /tests/Makefile.am
parentbb8262275f8bbf2b2264d68c5328a8c1a8c634d3 (diff)
BSSGP flow-control: Add unit test for algorithm tests
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index ce5fefbf..b489b3b2 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -3,7 +3,8 @@ INCLUDES = $(all_includes) -I$(top_srcdir)/include
check_PROGRAMS = timer/timer_test sms/sms_test ussd/ussd_test \
smscb/smscb_test bits/bitrev_test a5/a5_test \
conv/conv_test auth/milenage_test lapd/lapd_test \
- gsm0808/gsm0808_test gsm0408/gsm0408_test
+ gsm0808/gsm0808_test gsm0408/gsm0408_test \
+ gb/bssgp_fc_test
if ENABLE_MSGFILE
check_PROGRAMS += msgfile/msgfile_test
endif
@@ -44,6 +45,9 @@ timer_timer_test_LDADD = $(top_builddir)/src/libosmocore.la
ussd_ussd_test_SOURCES = ussd/ussd_test.c
ussd_ussd_test_LDADD = $(top_builddir)/src/libosmocore.la $(top_builddir)/src/gsm/libosmogsm.la
+gb_bssgp_fc_test_SOURCES = gb/bssgp_fc_test.c
+gb_bssgp_fc_test_LDADD = $(top_builddir)/src/libosmocore.la $(top_builddir)/src/gb/libosmogb.la
+
# The `:;' works around a Bash 3.2 bug when the output is not writeable.
$(srcdir)/package.m4: $(top_srcdir)/configure.ac
:;{ \