aboutsummaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorNeels Hofmeyr <neels@hofmeyr.de>2017-09-19 23:54:01 +0200
committerNeels Hofmeyr <neels@hofmeyr.de>2017-09-20 00:57:33 +0200
commit430636328c2fbd9fffc0eac5114462c200b7f2cb (patch)
tree9fbbecedf50ee4ff28e994855fb7cbf077a11319 /tests/Makefile.am
parent4a31ffa2f0097d96201f80305a0495c57552f0ad (diff)
fix vty regression: empty parent node
The recent exit-by-indent patch breaks a VTY case where a node is entered but directly followed by a sibling or ancestor without listing any child nodes. Regression introduced by I24cbb3f6de111f2d31110c3c484c066f1153aac9. An example is a common usage in osmo-bts, where 'phy N' / 'instance N' is a parent node that is commonly left empty: phy 0 instance 0 bts 0 band 1800 Before this patch, this case produces the error: There is no such command. Error occurred during reading the below line: bts 0 Fix indentation parsing logic in command.c to accomodate this case. Add a unit test for empty parent node. Change-Id: Ia0880a17ae55accb092ae8585cc3a1bec9986891
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 8935bf72..b1387174 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -222,6 +222,7 @@ EXTRA_DIST = testsuite.at $(srcdir)/package.m4 $(TESTSUITE) \
vty/fail_tabs_and_spaces.cfg \
vty/fail_too_much_indent.cfg \
vty/ok.cfg \
+ vty/ok_empty_parent.cfg \
vty/ok_ignore_blank.cfg \
vty/ok_ignore_comment.cfg \
vty/ok_indented_root.cfg \