aboutsummaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorDaniel Willmann <daniel@totalueberwachung.de>2012-12-26 00:12:21 +0100
committerHolger Hans Peter Freyther <zecke@selfish.org>2012-12-26 10:56:14 +0100
commit13bb169d71a7eff694b8a2ba24497ee08c73a090 (patch)
tree3573cc8b04dcbad3b6553a696039e15b732e3cc3 /tests/Makefile.am
parentaf723a4ed4c0232047590896935fb0b8da7c78a8 (diff)
tests: Don't delete atconfig in clean
This file is created in ./configure so we shouldn't remove it with make. Otherwise ./configure && make clean && make check fails with: make[3]: *** No rule to make target `atconfig', needed by `check-local'. Stop.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index cd3337d0..b60f6758 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -79,6 +79,8 @@ EXTRA_DIST = testsuite.at $(srcdir)/package.m4 $(TESTSUITE) \
msgfile/msgfile_test.ok msgfile/msgconfig.cfg \
logging/logging_test.ok logging/logging_test.err
+DISTCLEANFILES = atconfig
+
TESTSUITE = $(srcdir)/testsuite
check-local: atconfig $(TESTSUITE)
@@ -91,7 +93,6 @@ installcheck-local: atconfig $(TESTSUITE)
clean-local:
test ! -f '$(TESTSUITE)' || \
$(SHELL) '$(TESTSUITE)' --clean
- $(RM) -f atconfig
AUTOM4TE = $(SHELL) $(top_srcdir)/missing --run autom4te
AUTOTEST = $(AUTOM4TE) --language=autotest